Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Forums Advisor II
Posts: 967
Registered: ‎10-29-2009
My Device: 9550 Storm2/Verizon
My Carrier: Verizon

BB Maps Deletion

Having a preference for Google Maps, I deleted BB Maps.  I now want BB Maps back and all the download links while indicating OS 4.1 or "higher" do not allow for the download indicating my Storm doesn't meet the software requirements.  I imagine the or "higher" has limits.    How else can I get BB Maps back?


It was a dumb move on my part for which I hope there is a correction available.



Наглый пес! Вы должны быть благодарны мы даем Вам возможность проживать в нашем мире!
BB 9550 Verizon OS My Storm My Blackberry My Lifeline
If there is a Theme on my Blackberry, Hedone it!
If someone successfully helped you with an issue, say thank you by clicking "kudos" in their post and clicking the star.
Antiquis temporibus, nati tibi similes in rupibus ventosissimis exponebantur ad necem
If your issue has been solved, please mark the post that solved it for you!
Elite II
Posts: 9,321
Registered: ‎04-01-2008
My Device: Torch 9800
My Carrier: grameenphone

Re: BB Maps Deletion

You need to downland and install updated device OS in your desktop and then using application loader of Desktop Manager you can install BBmaps.

If your query is resolved then please click on Accept as Solution

Click on the LIKE on the bottom right if the post deserves credit

New Developer
Posts: 8
Registered: ‎09-02-2008
My Device: Torch
My Carrier: Vodafone UK

Re: BB Maps Deletion

Hi - I am trying to download the BlackBerry Maps from the website http://mobileapps.blackberry.com/devicesoftware/entry.do?code=maps directly through to the device get the following error message from the website "An unspecified error has occurred"


Then I attempted to download the zip file and push it through to the device using the PC Desktop manager, via this link:  https://www.blackberry.com/Downloads/entry.do?code=761C7920F470038D4C8A619C79EDDD62

I tried all the versions 1.2, 1.1 then 1.0.  Here's what happens with the version 1.2 I have downloaded and transfered to the device.


The program shows it is loaded (icon is in the download folder), but when I tried to access the program, the device gives the following error message:  "Error starting net_rim_bb_lbs: Class 'net.rim.device.internal.ui.Image'not found"


Any advice would be helpful, and thank you in advance for helping if possible.