Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎11-01-2009
My Device: Not Specified

Black or blank screen!

The screen on my storm recently quit displayin anything after about a day of screen disorientation... backlight still comes on but screen is blank (black)... i have read several posts about this same issue and the only solution was to return the phone... i got the phone through verizon but i am currently with another carrier and use it unlocked... just wondering if anyone has found a solution to this problem since i cant simply just return the phone... i loved the storm while it worked and i dont want to have to get a different phone! please help!

New Member
Posts: 1
Registered: ‎11-03-2009
My Device: Not Specified

Re: Black or blank screen!

Vanessa --

 

I experienced the same thing as well, but have my phone with Verizon. I had a flawless experience for two days after downloading the 5.0 OS (upgrade from the interim 4.7) and then, completely black. At first, I could awaken it occasionally, but eventually it just remained black (like yours, I could see the backlight on behind the screen, but the pixels were just black). I could even receive calls in this condition.

 

Verizon shipped a new Storm (tried to get a Storm2 at the store but they said no way) and I now have my third unit in less than a year.

Visitor
Posts: 1
Registered: ‎11-03-2009
My Device: Not Specified

Re: Black or blank screen!


vanessa_39402 wrote:

The screen on my storm recently quit displayin anything after about a day of screen disorientation... backlight still comes on but screen is blank (black)... i have read several posts about this same issue and the only solution was to return the phone... i got the phone through verizon but i am currently with another carrier and use it unlocked... just wondering if anyone has found a solution to this problem since i cant simply just return the phone... i loved the storm while it worked and i dont want to have to get a different phone! please help!


 

I had the exact same problem. Happened two days after upgrading os. The fix..For now was to reload the old os. I'm experimenting now to see if can figure out why it dose that, cause I really like the new os.