Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎04-23-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

Hi, first time poster here.

 

I have been experiencing the same problem on my Bold/Vista setup and have been pulling my hair out.

 

I tried the pinstack download and it did not help. I also tried everything else listed in this thread and every other one I could find on  the net to no avail.

 

However I have found a solution that I want to share with you all.

 

In Windows (I am using Vista), go into Control Panel > Device Manager. Expand the Disk Drives tree. Here you should see two drives relating to you Blackberry. Both of mine had yellow circles with exclamation marks in the to indicate they were not funtioning correctly. All I did was right click the drives, choose "uninstall", the go back, right click on the "Disk Drive" work, choose scan for changes. It added the drives in and hey presto straight away they show up in Windows Explorer.

 

Hope this works for all of you that are having problems!


Rob

New Contributor
Posts: 5
Registered: ‎04-04-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

Yes, the pinstack bat file worked for me too.

I think this problem is unique to refurbished Blackberries.  My old Bold bricked and I had to get a replacement.  Everything with the replacement worked fine EXCEPT for the mass storage/Media Sync, very frustrating.  I used the bat file and voila fixed within five minutes.

 

Here's the link again:

 

http://forums.pinstack.com/showthread.php?t=96938

New Contributor
Posts: 2
Registered: ‎03-31-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

It is definitely an issue with the refurbished Bold's. I'm so glad I read this whole thread.
New Contributor
Posts: 2
Registered: ‎07-30-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

ahhh finally!

 

The problem I was having on access was that the drive letter the BB was trying to use for mass storage was already assigned...

 

Once I knew to look for that it was easy to reassign.

 

Cheers,

 

Terry

Contributor
Posts: 15
Registered: ‎07-29-2009
My Device: 9000 bold

Re: BlackBerry Bold not working as a mass storage device

hi bifocals

ok i did all the stuff u just said and its still checking for updates i not sure how long this takes cause i never checked for updates on windows updates, its beem going for an hour,if it doesnt finish before to long i gonna crash out and leave it running and check it out in the morning and get back to thanks
New Contributor
Posts: 2
Registered: ‎09-04-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

Is there a fix for users with MACs?
New Contributor
Posts: 2
Registered: ‎09-22-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

Ok folks, here's the solution:

 

The problem is an incorrect setting within the OS, not a hardware or computer issue - Below are the instructions to fix it, but a word of warning: Once you are in the guts of the OS, don't be tempted to change any of the other settings - IT WILL KILL YOUR BERRY!!!

 

This is a bit complicated, but if you follow the instructions it will fix the problem

 

1) You first need to access the Help Me screen - Bold users hold down Alt+Shift+H on the homescreen - Others view info here.

2) Once you have the technical info on the screen go here on a different computer (Leave the Help Me screen open on your blackberry)

3) Enter the info from your Help Me screen & get the code it generates 

4) Enter the code into the Help Me screen - You won't see anything happening, but when you completely enter the code it will get you into the OS, or "escreen"

5) Don't be tempted to change any of the other settings - IT WILL KILL YOUR BERRY!!!

6) Go into engineering/usb/usb port information. Make sure that the media storage is set to enabled. If not click on it and toggle MS.

7) Escape out of everything, re-plug your berry into USB & you should be able to access it as a storage device.

 

Cheers! 

Dan

New Member
Posts: 1
Registered: ‎12-28-2009
My Device: 8800

Re: BlackBerry Bold not working as a mass storage device

Many thanks dmagstadt  !!!!!

 

That was THE solution!!!

 

Surely, I changed that parameter some time ago without knowing what I was doing...

 

 

A GOOD 2010,

FeW

New Member
Posts: 1
Registered: ‎01-02-2010
My Device: Bold 9000
My Carrier: 3

Re: BlackBerry Bold not working as a mass storage device

Hi,

i've just bought an used Bold and it seems i have the same problem with mass storage function.

My bb Bold OS is 4.6.0.303 (518) and my computer is a macbook with OS 10.6.2.

 

I've tried to use the short "complicated" guide posted by dmagstadt but the link for the escreen is no longer available. Any hint?

 

tnx for support

 

l.

 

New Contributor
Posts: 5
Registered: ‎04-04-2009
My Device: Not Specified

Re: BlackBerry Bold not working as a mass storage device

@leelin:  See my post above yours, go to http://forums.pinstack.com/showthread.php?t=96938