Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎03-21-2009
My Device: Not Specified

Blackberry 7520 Error 507 - Tried EVERYTHING

BlackBerry This is exactly what I tried so far: 1) Installed Desktop Manager 4.7 from the Blackberry Website (http://na.blackberry.com/eng/services/desktop/) 2) Installed OS version from the "Software Download for Nextel Communications Inc." download page (https://www.blackberry.com/Downloads/entry.do?code=C8ED21DB4F678F3B13B9D5EE16489088) for the 7520 3) Connected BB to computer. It shows the hourglass for around 5-6 seconds, and gives a 507 error. 4) I went to update. It asked me for the password, which I entered. 5) It asked which software to install. I just chose BB 3.1 System Software, Core apps and phone (version 4.1). 6) Connection to ROM (almost instantaneous, Erasing Applications (around 20 secs), Loading system software (around 20 secs), Waiting for device initialization (15 secs), the 507 error appears, uploading RAM image, connection to boot ROM (hangs for around 10 seconds) And I get an error "A fatal error has occurred while updating your device's software. Please try again" OK...so I tried to use Jl_Cmdr 1.9.1. 1) Press the key to continue 2) Y my bb has a password, entered password 3) Pressed 4 for wipe. Y I want to continue, typed blackberry. 1 second later goes back to that screen. 507. 4) Tried the Update again. Same exact thing happened as above. Then I tried this on my other comp (my current one runs windows 7, the other runs xp). Same thing happened...Tried doing that fix....disabled power off on all the hubs 1. On your computer, click Start > Settings > Control Panel. 2. In the Control Panel, double-click the System icon. The System Properties window opens. 3. Click the Hardware tab of the System Properties and click Device Manager. 4. In the Device Manager, double-click Universal Serial Bus Controllers. 5. Right-click the first USB root hub, and click Properties. 6. In the Properties window, click the Power Management tab. 7. Clear the Allow the computer to turn off this device to save power check box. 8. Repeat for all other USB root hubs. 9. Restart your computer. After that I went into C:\Program Files\Common Files\Research In Motion\AppLoader and did: loader.exe /nojvm went through the screens...and I noticed a few things: 1) Where it said "Blackberry 4.1 System Software" the action was UPDATE 2) Even though I just selected the bare minimum (phone, system software, core apps) it gave an error "This device does not have sufficient storage..." 3) Tried doing loader.exe (without /nojvm). It did the same thing as with the desktop manager...but now gave an error " Unable to communicate with the radio hardware. Please ensure that a charged battery is installed in the device and try the loading operation again. [P:0x0000000F]" Interesting huh... So what do you recommend I do?
New Contributor
Posts: 2
Registered: ‎03-21-2009
My Device: Not Specified

Re: Blackberry 7520 Error 507 - Tried EVERYTHING

update on the situtation:

This is what I did (on my Windows 7 Comp):
1) Uninstalled old Desktop Manager and Device software
2) Restarted
3) Downloaded and installed Desktop Software v4.2 SP2 without Media Manager (English) from the website (this btw took a CONSIDERABLY longer time than it did before...don't know whether that plays a role in anything)
4) Downloaded and Installed BlackBerry Handheld Software v4.1.0.534
5) Used Jl_Loader to wipe the blackberry (which btw took <2 seconds Smiley Sad + around a 10 second restart...)
6) Deleted Vendor.xml from C:\Program Files\Common Files\Research In Motion\AppLoader
7) Used Application Loader Wizard to update the blackberry (read radio software configuration took around 20 seconds, selected only the default components, erasing applications around 15, loading system software around 10, waiting for device initialization around to (507 screen...), connecting to boot ROM (around 10) )
8) error: Unable to communicate with the radio hardware. Please ensure that a charged battery is installed in the device and try the loading operation again. [P:0x0000000F]

so I went on my xp comp...
Followed exact same procedure...and minus the 20 second reading radio software config it went exactly the same way...

Then (only on the XP Computer):
1) uninstalled BlackBerry Handheld Software v4.1.0.534 and Desktop Software v4.2 SP2 without Media Manager (English)
2) Decided to give it one last shot and installed Desktop Manager 4.5.0 B17 Multilanguage - Without Media Manager
4) Asked me to restart, so I restarted
4) Installed BlackBerry Handheld Software v4.1.0.534
5) Wiped using Jl_Loader (again took < 2 seconds....)
Deleted C:\Program Files\Common Files\Research In Motion\AppLoader\Vendor.xml
7) Followed the same exact procedure and before (same exact timing, screens and whatnot showed) aaand fatal error

Well I am completely out of ideas
New Member
Posts: 1
Registered: ‎12-03-2009
My Device: Storm 9500
My Carrier: Vodafone UK

Re: Blackberry 7520 Error 507 - Tried EVERYTHING

Hi there, I know this is an old thread, but I thought I'd reply as it's the first result in Google for 'stuck at waiting for device initialization".  I had the following problems on my bb storm 9500;


  • Downloaded the lastest official handheld software from the Vodafone UK website
  • Left the phone upgrading and went for coffee
  • When I came back, the phone was stuck on the "Reload software: 507" screen.
  • No amount of rebooting etc would help.
  • Phone wouldn't show up in desktop manager
  • Phone wouldn't connect to Jl_cmdr
  • I could get the phone to start the re-flashing process with the battery out, but then it couldn't reconnect to it afterwards.
  • Finally, by doing a battery pull and plugging in the phone when the red LED was on, after having started Application Loader Wizard with the /nojvm option, I was able to get the device detected
  • However, this always hung at 'Waiting for Device Initialization' page

After hours of trying, I realised that you NEED to be using the OLDEST firmware you can get your hands on.  Now I don't know if I'm just being really thick, but I couldn't find any way of choosing which firmware to flash from the app loader wizard.  Therefore, I used a completely different computer, which had only the oldest official vodafone release on it.


Both computers were Windows 7 machines, and the firmware I used in the sucessful flash was - one (very long) reboot later, everything seems to be working!


Hope this helps people, feel free to drop me a pm if you have any questions.