Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Member
Posts: 1
Registered: ‎09-13-2012
My Device: Pearl 8130
My Carrier: VZW

Blackberry 8130 Bricked, any idea's?

I know this issue has been posted over and over, but i've scoured the internet and havent found anything that works yet. I've got an 8130 that has a 507 error. I bought the phone as a temp phone and a backup, and it worked for about 20 min today until I tried to update the software on it. It gets to waiting for device to initialize, the phone turns on and comes up with a 507 error. It then continues to connect and disconnect from the USB.


Heres what I've tried:


I'm not connecting the phone using a hub, its going straight into the PC's motherboard on all machines used.

I've adjusted all USB ROOT HUB settings on all machines used.

Attempted to wipe with JL_Cmder on a win 7 and xp machine but neither seemed to work. It would say connecting to device, then return to the main screen. Error log shows nothing.

I deleted the Vendor file and searched for others on all machines used

I attmped to use bbsak but it couldnt connect to the phone

Doest matter if i use loader, or loader with /NOJVM i get the same results

I've tried using BBDM 7.1 and 4.5 as well as uninstalling and reinstalling along with rebooting

I've tried a million different combos with battery in, battery out, etc.

Battery has been charging for a few hours so it should be good


I'm pretty sure the phone is bricked and beyond repair, but I thought I'd check here to see if anyone has any other ideas.

Posts: 539
Registered: ‎11-09-2012
My Device: BlackBerry Z10
My Carrier: AIS Thailand

Re: Blackberry 8130 Bricked, any idea's?

try checking with a local repair shop or your carrier?
If you have an answer to your question then please click “Accept as Solution”
Click on the LIKE on the bottom right if the post deserves credit.
BB 8700 -> Bold 9000 -> Curve 8520 -> Bold 9700 -> Curve 9320 -> Bold 9900 -> BlackBerry Z10 + PlayBook 64 GB Wi-Fi