Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Contributor
Posts: 41
Registered: ‎09-27-2010
My Device: Not Specified

Blackberry Browser not asking for authentication, taking some default credentials and failed to connect

Hi I am using Blackberry 9790 for testing my application.

In a Browser if I enter a specific url( which is not exposable and need to authenticate) It is saying that

"401 - Unauthorized : Access is denied" If I enter same url in android phone it is asking for authentication.

 

Please somebody help me why its not asking in the BB phone/simulator, do I need to set some settings?

and is it taking some default settings?

Elite II
Posts: 7,974
Registered: ‎06-01-2012
My Device: Curve
My Carrier: BSNL

Re: Blackberry Browser not asking for authentication, taking some default credentials and failed to connect

Hello khalandar

 

 

Please read this Knowledge base related to the error you're getting :

 

KB10971 : "Error 401: Unauthorized Access" appears when an attempt is made to browse to a secure website

___________________________________________________________________________

Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.
Contributor
Posts: 41
Registered: ‎09-27-2010
My Device: Not Specified

Re: Blackberry Browser not asking for authentication, taking some default credentials and failed to connect

Hi Thankyou for sharing KB, 

I am getting the same response(401: Unauthorized Access) trying with BIS, not with BES.

it leads many doubts for me

is BIS not handling the 'http Authentication' ?  if not can't we open secure authenticated url in Blackberry phone?

can we handle that locally in the device?

 

Please help me to understand this.

Elite II
Posts: 7,974
Registered: ‎06-01-2012
My Device: Curve
My Carrier: BSNL

Re: Blackberry Browser not asking for authentication, taking some default credentials and failed to connect

Hi there ,

 

So you're a BIS user , but you said you're using it for some application tests ,  Are you getting the same error message for most url you try to visit or it appear with specific websites ?

 

Can you try those steps :

 

1- Register your Handheld .

  • KB00510 : How to register a BlackBerry smartphone with the wireless network
  • Wait till a Registration messages comes in your message box.

2- Resend your Service Book

  • KB02830 : Send the service books for the BlackBerry Internet Service
  • ( Wait till a Registration Message comes in your message box for each email that you have configured on your device )

3-  Then perform a battery pull restart like this while the device is powered On remove your battery wait for a min. then reinsert it back

 

 Try it and let us know in detail about your progress or any error messages if you recieve .

___________________________________________________________________________

Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.
Contributor
Posts: 41
Registered: ‎09-27-2010
My Device: Not Specified

Re: Blackberry Browser not asking for authentication, taking some default credentials and failed to connect

Hi Prince,

 

I did both the steps and still I am getting the same response(401 - Unauthorized Access is denied due to invalid credentials) when I am trying to connect the authenticated url.