Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 1
Registered: ‎12-21-2011
My Device: Blackberry Torch 9800
My Carrier: o2

Blackberry Torch screen not working!

Right so I have had this problem for a month now and I have rang up repairs centres and never recieved the bags they send out. Its getting close to christmas now and I dont really want it to get lost or something silly!

So I was just wondering if anyone has had the same problem or knows how to fix it?


My screen is being really odd. It started off as when I slid it down inbetween it being slid out and slid down the screen would flash black. I got used to that after a while, as it didn't make the phone any harder to use.

Now sometimes when I slide it up or down, the screen will go totally black and do nothing. I could type stuff and then when it decides to work I can see what I have typed.

It also now sometimes goes multicoloured. Like, when a magnet is near a telly and it goes reds/blues/greens all over the screen. Well it does that every now and then, and is completely not working.


It is driving me mad! I will probably have to send it off, but if anyone has ANY solutions please reply! Thanks

New Contributor
Posts: 3
Registered: ‎01-03-2012
My Device: blackberry torch 9810
My Carrier: tbayltel/rogers

Re: Blackberry Torch screen not working!

i just sent mine in for repairs it started  going  a bit odd a week  more  ago. it does similar as you describe  without the colours. the screen goes black  and the function buttons wont work or  it will open up in  phone mode  and nothing else then i do a battery pull  and opens up ok  then , it  will go to a half screen when put horinzontal  and  seemingly freeze.   the first instance of a problem showed when playing with my new playbook i  did  a security wipe in the playbook  just  testing stuff out  and when i went to pair it   amd my phone  would not recognize  the bar code , it said it was not valid  after  a few  battery pulls  and sim card  pull it finally read it  and i was able to  pair it up again, second  weird ness  was camera  seemed  to have blue  purple  shadows  no matter where i looked to take a picture , i thought maybe  was jus a bit cold for the camera   and  later on the camera  seemed ok, and then last night  the screen went a deep greyish faded black and all hell went loose  i codunt  do much so i pulled the battery  sim card  did a total security on the phone  and it seemed to help   for a little bit then same thing. so last resort i took off my screen protector  thinking maybe i was loosing sensitivity but it did not help.  it isbeing sent out for repairs, i do not know the cause of this  the retailer  looked  to see if it  had not been in the water    and i  got this phone in october 2011. i am not impressed