Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 4
Registered: ‎05-23-2013
My Device: 9900
My Carrier: Unlocked

Blackberry going ape s**t

Hi, I have a Blackberry Bold 9900 which was working fine a week ago but after that it started acting up. At first, the lock button started acting funny and did not function as it normally did but it randomly started working after I slapped it a little. After that, the problem started recurring every couple of hours or so and sometimes it fixed itself and sometimes I had to slap it a little to get it to work properly but recently (3, 4 days ago) the trackpad also started acting funny and slapping was the only that fixed these two. Whenever it starts going crazy, the trackpad/sensor works fine on the homescreen but when I go into the messages app or any other app, up and down doesn't work at all while it works fine at the same time on the homescreen and left and right work fine too. I've researched a bit and I think it may have water-damage, but I don't remember spilling and water on it or using it in rain or a shower or something. I also tried reloading the OS using BSAK but that didn't work as well. Can someone please tell me what this could be? Any help would be greatly appreciated Thank you for reading

Guru II
Posts: 21,605
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Blackberry going ape s**t

If the device got moisture damage then you need to stop using it. Pull the battery and put the device in a bag of uncooked rice for a few days. if you don't do this you risk damaging the device further.

You don't have to get the device "wet" to get moisture damage. Condensation or high humidity will cause the same type of damage.

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!