Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Member
Posts: 1
Registered: ‎04-17-2011
My Device: Bold 9650
My Carrier: Verizon

Bold 9650, issues with internet browser after OS update

I have the Bold 9650 with Verizon and have since March 2010. I've never had problems with using mobile web until I updated it to After that, it was telling me that I had to be connected to a Wifi network in order to use the service. I connected to the Wifi at my dad's and it worked fine, but before that I had my "own" Wifi network that wasn't actually connected to the internet and it worked perfectly fine. Now, even connected to a proper wifi connection, the error still occurs.

Should I update the OS to the new 6 or will that not help at all?

New Contributor
Posts: 2
Registered: ‎07-31-2010
My Device: BB Bold
My Carrier: Verizon

Re: Bold 9650, issues with internet browser after OS update

I also have the Bold 9650 and absolutely love it. Well, that is before I updated to OS6 and my phone now has gone beserk. I got the same error about the Wifi. I also keep getting the email saying my phone is registered to the network. Of course because it keeps re-registering, I have to keep signing in everysingle time to my apps (Facebook). To top things off, I was able to use it to view my home security system cameras. Then it stopped.
Support cannot figure it out so I have to get a new phone. I know BB are not the top of the line in global phones, but I like them. I do not know what updating to the OS6 did, but I know my phone now is driving me crazy. I am sick ot it. Any ideas?
Super Contributor
Posts: 329
Registered: ‎01-31-2011
My Device: Bold 9700 v6.0.0.576
My Carrier: Orange UK

Re: Bold 9650, issues with internet browser after OS update

Try this:

Delete all wifi profiles if possible and add the one you want it to work and see if it works.

If not, try a battery pull. Sometimes it solves many problems.

If everything fails, delete all wifi profiles, back up your data using desktop manager.

Check for updates using desktop manager, if no updates are available, choose view other versions and select the current version and install.

Try connecting to wifi and let us know the results.
Install this on your phone, it helps: http://us.blackberry.com/apps-software/protect/

Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!