Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎08-23-2013
My Device: Bold 9780
My Carrier: virgin
Accepted Solution

Bold 9780 doesn't get any IP address while tethering through USB on Mac OS X

Hello everybody,

 

I have an issue with my Bold 9780:

 

I use it as a tethered data modem for my Mac Book Air. The Blackberry is connected with an USB cable to my laptop. When I click on "Connect Blackberry-PIN", Mac OS does connect to the handeld successfully, but there is no IP address assigned ; thus making the IP connction to the Internet impossible.

 

If I use the same mobile phone and the same laptop, but this sitme through the Bluetooth connection, everything works fine, I get an IP address and can connect to the Internet.

 

The network settings are equal on both connections (USB and Bluetooth).

 

So what's wrong with the USB connection?

 

Here are some informations on my handeld:

 

Blackberry Bold 9780

OS version: 6.0 bundle 2949

Mobile operator: virgin mobile france

 

There is nothing special on the PPP logs on the Mac OS console, except the fact that there are plenty of IPCP lines and then a "Maximum Config-Requests exceeded".

 

Of course when I use the Bluetooth connection I got a different message after the IPCP Config-request.

 

Fri Aug 23 15:21:05 2013 : CCLWrite : ATE0V1\13\10
Fri Aug 23 15:21:05 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : AT\13
Fri Aug 23 15:21:06 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : ATS0=0\13
Fri Aug 23 15:21:06 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : ATX\13
Fri Aug 23 15:21:06 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : AT\13
Fri Aug 23 15:21:06 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : AT+CGDCONT=1,"IP","virgin-mobile.fr"\13
Fri Aug 23 15:21:06 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : AT+MACMODE=1\13
Fri Aug 23 15:21:06 2013 : CCLMatched : OK\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : AT+NT\13
Fri Aug 23 15:21:06 2013 : CCLMatched : ERROR\13\10
Fri Aug 23 15:21:06 2013 : CCLWrite : AT+GCAP\13
Fri Aug 23 15:21:09 2013 : CCLWrite : ATD*99#\13
Fri Aug 23 15:21:09 2013 : CCLMatched : CONNECT\13\10
Fri Aug 23 15:21:10 2013 : CCLExit: 0
Fri Aug 23 15:21:10 2013 : Serial connection established.
Fri Aug 23 15:21:10 2013 : using link 0
Fri Aug 23 15:21:10 2013 : Using interface ppp0
Fri Aug 23 15:21:10 2013 : Connect: ppp0 <--> /dev/cu.BlackBerry-
Fri Aug 23 15:21:11 2013 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7a576c2d> <pcomp> <accomp>]
Fri Aug 23 15:21:11 2013 : rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth pap>]
Fri Aug 23 15:21:11 2013 : No auth is possible
Fri Aug 23 15:21:11 2013 : lcp_reqci: returning CONFREJ.
Fri Aug 23 15:21:11 2013 : sent [LCP ConfRej id=0x0 <auth pap>]
Fri Aug 23 15:21:11 2013 : rcvd [LCP ConfRej id=0x1 <magic 0x7a576c2d> <pcomp> <accomp>]
Fri Aug 23 15:21:11 2013 : sent [LCP ConfReq id=0x2 <asyncmap 0x0>]
Fri Aug 23 15:21:11 2013 : rcvd [LCP ConfReq id=0x1 <asyncmap 0x0>]
Fri Aug 23 15:21:11 2013 : lcp_reqci: returning CONFACK.
Fri Aug 23 15:21:11 2013 : sent [LCP ConfAck id=0x1 <asyncmap 0x0>]
Fri Aug 23 15:21:11 2013 : rcvd [LCP ConfAck id=0x2 <asyncmap 0x0>]
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : sent [IPV6CP ConfReq id=0x1 <addr fe80::2a37:37ff:fe1c:58ce>]
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfReq id=0x2 <addr 169.254.1.1>]
Fri Aug 23 15:21:11 2013 : ipcp: returning Configure-ACK
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfAck id=0x2 <addr 169.254.1.1>]
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfNak id=0x1 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : rcvd [IPV6CP ConfReq id=0x3 <addr fe80::0000:0000:0000:0011>]
Fri Aug 23 15:21:11 2013 : sent [IPV6CP ConfAck id=0x3 <addr fe80::0000:0000:0000:0011>]
Fri Aug 23 15:21:11 2013 : rcvd [IPV6CP ConfRej id=0x1 <addr fe80::2a37:37ff:fe1c:58ce>]
Fri Aug 23 15:21:11 2013 : sent [IPV6CP ConfReq id=0x2]
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfNak id=0x2 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : rcvd [IPV6CP ConfAck id=0x2]
Fri Aug 23 15:21:11 2013 : local LL address fe80::2a37:37ff:fe1c:58ce
Fri Aug 23 15:21:11 2013 : remote LL address fe80::0000:0000:0000:0011
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfNak id=0x3 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfReq id=0x4 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfNak id=0x4 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfReq id=0x5 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfNak id=0x5 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : sent [IPCP ConfReq id=0x6 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:21:11 2013 : rcvd [IPCP ConfNak id=0x6 <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]

 

[...]

 

Fri Aug 23 15:08:10 2013 : sent [IPCP ConfReq id=0xff <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:08:10 2013 : rcvd [IPCP ConfNak id=0xff <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Fri Aug 23 15:08:10 2013 : IPCP: Maximum Config-Requests exceeded

 

Thanks for your help.

Nicolas

Retired
Posts: 4,285
Registered: ‎07-26-2010
My Device: Q10/Q5/Z10/9930/9860/9310

Re: Bold 9780 doesn't get any IP address while tethering through USB on Mac OS X

Hey nikolaii,

Welcome to the BlackBerry Support Community Forums.

 

Thanks for the question.

 

I would suggest following these detailed instructions to get the tethered modem working via USB: www.blackberry.com/btsc/KB19641

 

Let me know if you have any more questions.

 

Cheers.


-ViciousFerret


 


Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp


Be sure to click Like! for those who have helped you.

Click  Accept as Solution for posts that have solved your issue(s)!



New Contributor
Posts: 2
Registered: ‎08-23-2013
My Device: Bold 9780
My Carrier: virgin

Re: Bold 9780 doesn't get any IP address while tethering through USB on Mac OS X

Hi, thank you for your answer, but I already did follow the page you mentioned to setup my connection. So I could connect to the Blackberry without any problem, but couldn't get any IP address. After some digging on the Internet, I found something interesting related to PPP connections: the TCP header compression could be the cause. So I disabled it (it's in the connection advanced options, the PPP tab, uncheck the "Use TCP header compression"), and since then it's working like a charm! Regards, Nicolas