Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
New Contributor
Posts: 9
Registered: ‎09-08-2010
My Device: Bold 9900, Pearl 8130
My Carrier: Bell Canada

Bold 9900, Pearl 8130 Bluetooth Problems

[ Edited ]

Hi,

 

I recently upgraded from Pearl 8130 to Bold 9900. Due to this I no longer have internet connection on my Pearl. I tried connecting my Pearl to Bold in hopes of getting internet on Pearl but I am having problems.

 

The two devices pair properly but when I choose 'Connect' on my Pearl, the bluetooth indicator (the blue LED) blinks once and I immidiately get a 'Connection with Bold failed' message. I don't see an option to 'Connect' on my Bold.

 

Now, the weird part is, when I chose to transfer a picture from my Pearl to Bold, it accepted and it worked fine!

 

Here's what I'm doing:

1. Enabled Bluetooth on both Pearl and Bold.

2. Set the Pearl to listen from Bold and got the Bold to search.

3. Entered the passkey (which is the same on both devices)

4. Bold says Pairing complete.

5. On the Device List, Pearl becomes normal from bold as soon as the pairing complete message goes away.

6. Pearl keeps showing 'Waiting for Bold'

 

Then I tried the other way around and got the Pearl to search while Bold listenes. This time they pair and when the 'Pairing completed' message goes away on Bold, it again turns Pearl to normal letters from bold letters. Pearl then asks me to connect to Bold and I choose Yes and Bold asks the same thing, I choose Yes but Pearl then shows me the 'Connection failed' message.

 

Can someone help me here??

 

EDIT: I'm using the most uptodate OS on both phones. Pearl = 3.4.0.20 and Bold = 7.0.0.2406

 

EDIT: So now, both devices are paired but 'Connect' option only shows up on Pearl and when I choose it and accept from Bold, it shows 'Connection failed' message...