Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Member
Posts: 1
Registered: ‎04-10-2012
My Device: Bold - 9900
My Carrier: O2

Bold 9900 Service Issues

Im unaware whether my phone has a faulty service reciever or if the signal in my area is bad, but most of my texts do not send and i recieve error messages such as 'Retries Exceeded' 'Mobile Equipment Status Failed' and i think another one.

But recently my phones service will go from 3G full bar strength to searching for service untill it gives up and says that i have no service, when this happens - and it has happened 4 times today - i turn of mobile network in the manage connections tab and turn it back on and it will go back up to 3G and I wont have moved at all so its not like i went into a building that blocks signal or anywhere that i would loose signal. 

I was just wondering if this is a known error or if its just my phone.

Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Bold 9900 Service Issues

Hello Daavviiee and welcome to the BlackBerry® Support Community Forums.


Sorry to hear you are having issues with your BlackBerry® Bold™ 9900 smartphone and mobile network coverage.


SMS or text messaging is a carrier controlled feature. Since you are experiencing issues with this as well as mobile coverage, it would be advised to contact your mobile carrier for investigation.


Hope this helps!



Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

New Contributor
Posts: 7
Registered: ‎07-05-2012
My Device: Bold 9780
My Carrier: MTN nigeria

Re: Bold 9900 Service Issues

Hi guys ps I need help, my blackberry 9900 had being displaying sos in the network bar since 3 days now, I've tried battery pull a hundred times, switched off/on the network several times still no network. Am runinng an OS