Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 2
Registered: ‎02-23-2009
My Device: Not Specified
Accepted Solution

Bold Speakers don't work with battery cover on

Hi Everyone,

 

I'm a relatively new Blackberry owner.  I have the Bold for the past two months and it's been great. One of the things that impressed me initially was the quality of sound from the internal speakers.  For the first several weeks everything worked fine. In the past fews days I noticed I was missing calls because I didn't hear the ring. Then I noticed I couldn't hear songs well when played from the Music Library.  Thinking it was some system glitch, I pulled out the battery and it worked for a while but then stopped.  Only after examining more closely did a realize that the speakers work great with the batter cover off, but as soon as I put it back on it makes them almost inaudible

 

Right now I'm making do with the cover not clicked in fully at the top.  In this position the speakers sound fantastic but the back could click in at any time and squelch the sound agian.  Obviously this not a good long-term fix. I've searched these boards and haven't found a similar problem.  Right now I'm thinking about ordering a replacement cover from Amazon to see if it could be that my current cover is "bent" or otherwise doing something weird to the speakers.

 

I'm wondering if anyone else has run into this and found a solution.

 

Thanks in advance for your help.

 

Rusty

 

Highlighted
Contributor
Posts: 11
Registered: ‎01-29-2009
My Device: Not Specified

Re: Bold Speakers don't work with battery cover on

[ Edited ]
Wow, That's a weird one, never heard of this problem before. If you have insurance for your phone go to the store and get a new one that's what I would do or you can use your warranty with blackberry and get a new one from them. I know this is not alot of help, but why bother with a different battery cover when you can probably get a whole new phone. If you do decide to go with the new battery cover reply back and let us know if the problem is solved.
Message Edited by latavong2009 on 02-24-2009 06:16 AM
Elite I
Posts: 6,343
Registered: ‎08-19-2008
My Device: 9800 - OS 6.0.0.246

Re: Bold Speakers don't work with battery cover on

I've never had problems with the cover. I even have mine in an Innocase Hybrid from Seido and can still hear the speakers fine.

 

I agree. Before spending $$$ take in into your carrier's store for an exchange if it's not too late. Or have then try a different cover in the store to see if it is really the cover or not.

 

_______________________________________________________________________________________________________________
If someone has been helpful please consider giving them kudos by clicking the star to the left of their post.
Remember to resolve your thread by clicking Accepted Solution.
New Contributor
Posts: 2
Registered: ‎02-23-2009
My Device: Not Specified

Re: Bold Speakers don't work with battery cover on

Thanks for the quick responses.  I took it to an ATT store on the way home and they said the same thing "wow, that's a weird one".  I now have a replacement (under warranty) and enjoying my phone again.  I also just ordered a hard case because I'm suspicious that the cause of the problem was the frame being a bit bent.  I'm going to do my best to protect my new unit.  

 

Rusty

 

New Member
Posts: 1
Registered: ‎03-08-2009
My Device: Not Specified

Re: Bold Speakers don't work with battery cover on

I'm having the exact same problem, with the cover not clicked in the speakers sound phenominal.. but with it clicked into place they are muted alot..  Have not found a soulition yet tho =(

New Member
Posts: 1
Registered: ‎02-10-2009
My Device: Not Specified

Re: Bold Speakers don't work with battery cover on

I have the same problem. I'm missing calls because I can't hear the tone and I can't really carry the phone with the cover half clicked all the time. The Bold has never been dropped and I always carry it in the holster that came with the phone. I purchased it at the begging of February and I have insurance so I'm going to take it back to AT&T.
New Contributor
Posts: 4
Registered: ‎06-20-2009
My Device: Bold

Re: Bold Speakers don't work with battery cover on

I am having the same issue with my speakers.  They worked great for about a month then all of the sudden it wasn't load any more.  I miss calls all the time now because I can't hear it!  I'm sure anyone understands how frustrating this is when we pay so much for our BB's.

 

On CrackBerry, there are several posts there as well about this very thing.  One person found that if you squeeze the area at the top of the phone, by the camera flash on the back and LED on the front, that the sound came back.  It worked for me as well, so it sounds like there is a hardware issue with the Bold speakers.  

 

If anyone knows how to fix, please respond.  I am very technically savy (I have had to replace my screen) so if there is a fix, I'm sure I could do it.

 

I have now noticed that the sound is all but gone.

 

Thanks in advance for any help!

 

shorrar

New Contributor
Posts: 6
Registered: ‎06-27-2009
My Device: Not Specified

Re: Bold Speakers don't work with battery cover on

I had the same problem and after reading this tried this technique (squeezing between LED and flash) and it worked like a charm.  Thank you!
New Contributor
Posts: 4
Registered: ‎06-20-2009
My Device: Bold

Re: Bold Speakers don't work with battery cover on

Yeah pinching the phone works for a while then it gets to where it doesn't work at all. 

 

Btw, I knew the phone wasn't very old because the guy I bought it from said he only had it a couple of months before his company purchased him a phone.  So, I contacted AT&T and found out the phone was still under warranty and they are sending me a new phone even though I bought it from someone else.  I couldn't believe it.  Thank you AT&T!!

 

But to me this still sounds like a hardware issue that RIM needs to look at.

 

shorrar

 

New Member
Posts: 1
Registered: ‎10-17-2009
My Device: Not Specified

Re: Bold Speakers don't work with battery cover on

Hi there, Was frustrated with the exact same problem myself until I figured the sqeeze method out, however it only worked momentarily and when I let go the sound would no longer work. So I simply took the cover off, rolled a small piece of tissue between my fingers and placed it just over the camera flash and replaced the cover. Worked a treat so far!