Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎01-07-2013
My Device: 9000 Bold
My Carrier: AT&T

Re: Bold will not charge / turn on, battery already replaced

I had this happen to me today.  I was charging from my laptop USB port.  Red light was on but wouldn't charge. I took the battery out and tried to keep it plugged in and wait for the 'no battery' notation popped up but only the red light would come on.  I then plugged into a wall outlet without the battery and the 'no battery' notation now came up.  I put the battery back in and it is now charging.  Thanks! 

New Contributor
Posts: 4
Registered: ‎09-15-2014
My Device: 9900
My Carrier: MTN

Re: Bold will not charge / turn on, battery already replaced

My phone goes off after 20 seconds of restart. I have replace battary but still facing same problem. I need help pls
Posts: 95,139
Likes: 24,498
Solutions: 6,376
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Bold will not charge / turn on, battery already replaced

Try starting up in Safe Mode, and then deleting third party applications.

 

Article ID: KB17877 How to start a BlackBerry smartphone in Safe Mode http://www.blackberry.com/btsc/KB17877



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Member
Posts: 1
Registered: ‎02-10-2016
My Device: Bold 9900
My Carrier: 2032

Re: Bold will not charge / turn on, battery already replaced

This is the same problem I am currently experiencing. Someone come to my rescue please. I have been offline for a month now. Thank you