Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Developer
Posts: 71
Registered: ‎12-26-2008
My Device: Not Specified
Accepted Solution

Can I use BlackBerry Softwares with version numbers >= 4.5

I have BB Curve 8320. Can I use BlackBerry Softwares (Blackberry JDE, BB desktop manager, etc) with version numbers >= 4.5 for my device.

 

Posts: 96,070
Likes: 24,627
Solutions: 6,422
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Can I use BlackBerry Softwares with version numbers >= 4.5

yes, you can.

 

You can also use Desktop Manager version 4.6 and 4.7



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Highlighted
Super Contributor
Posts: 414
Registered: ‎04-02-2008
My Device: Q10 OS 10.1, PlayBook (WiFi 64 Gig)

Re: Can I use BlackBerry Softwares with version numbers >= 4.5

Desktop Manager has always had backwards compatability in my (almost 10 year) experience.  There are older versions of Desktop Manager that won't have full functionality or won't work at all with newer devices - specifically you must have DM v4.2 or higher with devices released after the first Pearl (8100).

 

JDE doesn't "work" with your BlackBerry, it's a Development Environment for writing programs for the BlackBerry, so the question doesn't really have any relevance - EXCEPT that if you use a JDE that's later than your OS and use features only available in the version you're using or later, obviously the program you develop will not work properly on your BlackBerry.

 

Jerry