Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 8
Registered: ‎04-06-2008
My Device: Not Specified
Accepted Solution

Can't delete text message

I can't delete a text message from my 8830, though I've tried many times.  The SMS folder shows "no messages" and the message box shows "no messages" but on the main screen, the text message still appears under the message banner.  Any suggestions?
Trusted Contributor
Posts: 168
Registered: ‎04-01-2008
My Device: Blackberry Bold

Re: Can't delete text message

Try to remove the battery with the phone on, wait 30 seconds, then replace the battery. Let us know if this fixes it.
CEO/Editor In Cheif
www.SmartphoneNation.com

Highlighted
New Contributor
Posts: 8
Registered: ‎04-06-2008
My Device: Not Specified

Re: Can't delete text message

That did it.  Thanks!
New Member
Posts: 1
Registered: ‎06-16-2008
My Device: Not Specified

Re: Can't delete text message

Thanks - just tried this for my 8800 and it fixed it too Smiley Happy

Just out of interest, any idea why this happens and why the fix works?

New Member
Posts: 1
Registered: ‎04-08-2009
My Device: Not Specified

Re: Can't delete text message

FYI, works on the 8120 too!

 

 

New Member
Posts: 1
Registered: ‎04-14-2009
My Device: Not Specified

Re: Can't delete text message

This also works on 8700c. Thanks!
New Member
Posts: 1
Registered: ‎09-04-2010
My Device: Storm
My Carrier: Verizon

Re: Can't delete text message

[ Edited ]

I tried taking out the battery for 30 secs and turning it back on, but i still could not delete a certain message using a normal means.  I ended up having to go to the sms inbox folder and deleting the messages there.

New Member
Posts: 1
Registered: ‎04-01-2011
My Device: Not Specified

Re: Can't delete text message

[ Edited ]

Works on 8520 as well BUT on certain social networks (Farcebook) I had to read the full message first?

Either way it worked message gone!