Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 7
Registered: ‎06-04-2012
My Device: Blackberry Bold 9780
My Carrier: Vodafone

Can't install new language packs !

Hi guys,

 I'm trying to add new language packs to my bold 9780 but I can't find the option,I get to choose from the already installed languages and I'm unable to add a new one.Do I need to re-install the OS?

Thanks in advance

Hall of Famer III
Posts: 57,523
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't install new language packs !

Hi and Welcome to the Community!

 

Please refer to this KB:

  • KB13067 How to obtain language packs for BlackBerry smartphones

Amy_dominguez wrote:

Do I need to re-install the OS?


Most likely yes...you need to choose the OS package that contains the languages you need, install that OS to your BB, and then activate the languages you desire.

 

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎06-04-2012
My Device: Blackberry Bold 9780
My Carrier: Vodafone

Re: Can't install new language packs !

Thanks alot for your reply,i've already tried the steps mentioned in the KB article,the problem is that the language pack i want to install doesn't appear in there,i also tried to reinstall the OS SW,i only got 2 options,either repair or remove,repair didn't change anything and i dunno if removing the SW would be the correct thing to do.

If i remove it and install another OS SW that supports the language i want to install will it work with my SIM card ?

Hall of Famer III
Posts: 57,523
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't install new language packs !


Amy_dominguez wrote:

Thanks alot for your reply,i've already tried the steps mentioned in the KB article,the problem is that the language pack i want to install doesn't appear in there


You are going to need to be more explicit than that...I have no idea where "in there" is...please provide the steps you take, the results you expect, and the results you receive.


Amy_dominguez wrote:

i also tried to reinstall the OS SW,i only got 2 options,either repair or remove,repair didn't change anything and i dunno if removing the SW would be the correct thing to do.


That means that you already have installed, to your PC, the BB OS package you are attempting to install. If it does not contain (as offered in the RIM Desktop Software or Loader.exe) the language you desire, then you need to remove that OS package from your PC and install a different one that, hopefully, contains the language you need.


Amy_dominguez wrote:

If i remove it and install another OS SW that supports the language i want to install will it work with my SIM card ?


The SIM card and the OS package are not related. The only thing that is related is the source (carrier) of the OS package and the carrier for which your BB was originally manufactured. If they are not the same, then after you install to your PC the BB OS package, you need to find and delete one (and perhaps 2) VENDOR.XML file...if you do not delete that, the OS package will not work for your BB.

 

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎06-04-2012
My Device: Blackberry Bold 9780
My Carrier: Vodafone

Re: Can't install new language packs !

I'm sorry if i didn't provide much details,what i did was :

1st from my BB : went to Option,Language ,Input language ,i already have some installed but the one i want to add " Spanish " doesn't appear .

2nd from BB Desktop SW:Application,Language and Input support,again Spanish doesn't appear .

 

I remember having Spanish before in the installed languages,i might have uninstalled it by mistake while trying to add empty space.

 

My BB was manufactured for Mobinil Egypt but it's working with my Vodafone SIM card,i assume the file you were talking about is already deleted.

 

I'm already downloading Spanish SW for the same OS my BB has installed,let's hope it works ! f not i'll reinstall the other SW again.

Highlighted
Hall of Famer III
Posts: 57,523
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't install new language packs !

I think you are on the right track...please feel free to come back with any further questions that come about.

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎06-04-2012
My Device: Blackberry Bold 9780
My Carrier: Vodafone

Re: Can't install new language packs !

Well, no luck,i followed the installtion wizard,installed but actually nothing !

Hall of Famer III
Posts: 57,523
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't install new language packs !

Again, I ask you, please be more explicit. Your economy with words leaves just too much room to guess. Tell us exactly what you did, exactly how each step went, exactly what you expected from each step, and exactly what resulted from each step.

Thanks.


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎06-04-2012
My Device: Blackberry Bold 9780
My Carrier: Vodafone

Re: Can't install new language packs !

Ok, i went to this link : http://us.blackberry.com/support/downloads/download_sites.jsp i downloaded the same version of the OS i've installed now on my BB but in Spanish for the same carrier  ( 9780M_PBr6.0.0_rel2949_PL6.6.0.236_A6.0.0.668_Vodafone_Spain ) ,the wizard started the installtion,it took a few minutes ,it seemed to be installed,according to what appeared on my PC  but nothing changed on my BB.

 Can i reset my BB to factory defaults?i remember that having many language packs installed before,so may be if i reset it to factory defaults i'll have the original options again.

Hall of Famer III
Posts: 57,523
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't install new language packs !

[ Edited ]

Amy_dominguez wrote:

the wizard started the installtion


What "wizard", exactly?


Amy_dominguez wrote:

it seemed to be installed,according to what appeared on my PC  but nothing changed on my BB. 


When you ran that "wizard" (whatever that might have been), was there not a section for you to select the things that it would install to your BB? Included inside of there are the language packs...you must, during the OS load to your BB, select the languages you wish to be installed to your BB.


Amy_dominguez wrote:

 Can i reset my BB to factory defaults?


Of course:

  • KB31291 How to reset a BlackBerry smartphone to factory settings using BlackBerry Desktop Software 6.1

But, that will function based on the OS Package that is installed to your PC...it has no way of knowing truly what was originally on your BB.


I honestly believe that you did not select the languages during the OS load, and that's why they aren't being presented to you on your BB. If you now launch the Desktop Software again, you should be able to add just the things you desire:

  • KB14473 How to install an application on a BlackBerry smartphone using the BlackBerry Desktop Software

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................