Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎08-31-2012
My Device: Blackberry Curve 8520
My Carrier: Orange

Cant pay for an app of blackberry app world (version 4.63)


Today I tried purchasing an app off the app world version 4.63 but it wouldn't let me puchase it. Also I can't click on my payment options a green circle comes up when I click it but it does nothing. I upgraded my app world to the new version and ever since then I can't but an app I can download free apps but can't buy apps please help!
Posts: 96,064
Likes: 24,621
Solutions: 6,420
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Cant pay for an app of blackberry app world (version 4.63)

I wonder if your BlackBerryID needs updating.


I would suggest this:

  • Go to Options > Device > Applications and scroll to the AppWorld application and don't click on it, just scroll to it. Click Menu > Delete and remove the application.
  • Now, do a reboot: With the BlackBerry device powered ON, remove the battery a few seconds and then reinsert the battery to reboot.
  • Finally, use your BlackBerry browser to go to www.blackberry.com/appworld and download/install the AW  application again.

1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
Posts: 6
Registered: ‎11-20-2012
My Device: curve 8520
My Carrier: vodacom

Re: Cant pay for an app of blackberry app world (version 4.63)

I too have the same problem. I have a blackberry curve 8520. I have tried deleting, rebooting, etc but still the same. Was wondering if you came right and what you did?