Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Developer
Posts: 88
Registered: ‎05-24-2009
My Device: Not Specified

Curve 8900 w/ EDGE system requirements problem

Hi.

 

I have  a curve 8900 w/ a data plan from Rogers in Canada. However i seem to be unable to download the appworld becuase of the error :"Sorry, your device does not meet the system requiremetns that are needed to support BB App World". Any ideas why this is happening? I do have a data plan, i am in Canada. It seems like i am meeting the requirements.

 

Regards 

Hall of Famer III
Posts: 58,470
Registered: ‎11-28-2008
My Device: DTEK50 (AAI82), PRIV (AAI795), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Curve 8900 w/ EDGE system requirements problem

Hi and Welcome to the Forums!

 

Here is the requirements section of the App World website. Make sure you meet all conditions or it indeed will not work.

 

http://na.blackberry.com/eng/services/appworld/download.jsp#tab_tab_system_requirements

 

Best!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Developer
Posts: 88
Registered: ‎05-24-2009
My Device: Not Specified

Re: Curve 8900 w/ EDGE system requirements problem

I checked the requirements before, and it seems that i am meeting all of them.

1. BlackBerry® Device Software version 4.2 or higher: Platform 4.2.0.69

2. BlackBerry smartphones with trackballs or SurePress™ touch screen: Yep

3. BlackBerry App World is only available to customers in US, Canada and UK and may not be available on all network: Canada & Rogers

4.  To use BlackBerry App World, you require a service plan that includes access to the BlackBerry® Browser: I have a data plan. What exactly is meant by access to the BB Browser?

 

Regards,

 

Hall of Famer III
Posts: 58,470
Registered: ‎11-28-2008
My Device: DTEK50 (AAI82), PRIV (AAI795), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Curve 8900 w/ EDGE system requirements problem

BB Browser is the web browser on the device. The easiest way to install App World, IMO, is to, on a PC, go to this site and have a link sent to your device...

 

http://na.blackberry.com/eng/services/appworld/download.jsp#tab_tab_download

 

Then, on your BB, clicking that link (from the email you will recieve) will launch your browser and go to the site from which the install will happen. Try that method (unless that's what you already did) and see what happens.

 

 

 

 


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Developer
Posts: 88
Registered: ‎05-24-2009
My Device: Not Specified

Re: Curve 8900 w/ EDGE system requirements problem

I've tried that, and every single other method there.

I went to google and did a lokoup for BB appworld, (on the device), went to the link and clicked download the app world....systems requirements error. I tried doing it from my computer over IE w/ the activeX control on IE7.

All the method give me the same error.

 

Any other ideas on what to do? 

Hall of Famer III
Posts: 58,470
Registered: ‎11-28-2008
My Device: DTEK50 (AAI82), PRIV (AAI795), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Curve 8900 w/ EDGE system requirements problem

Wait...hang on...I don't think the "Platform" number you quoted is considered your device version level... Rather, it's the first part of that line in the About screen...

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Developer
Posts: 88
Registered: ‎05-24-2009
My Device: Not Specified

Re: Curve 8900 w/ EDGE system requirements problem

In that case the line is v.4.6.1.94(Platform 4.2.******

So i am still above the min reqs.  

Hall of Famer III
Posts: 58,470
Registered: ‎11-28-2008
My Device: DTEK50 (AAI82), PRIV (AAI795), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Curve 8900 w/ EDGE system requirements problem

Well this does sound odd. Let's wait a bit to see if anyone else has experienced this similar or same issue. I do have, as a later option, the ability to escalate to RIM...but let's hold back on that for the moment...

 

In the meantime, here's another article that may go deeper into requirements...not sure if it'll help...

 

http://na.blackberry.com/eng/support/BlackBerry_App_World_FAQ.pdf

 

And here's the App World direct support page...again, not sure it it'll help...

 

http://na.blackberry.com/eng/support/blackberryappworld.jsp


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Developer
Posts: 88
Registered: ‎05-24-2009
My Device: Not Specified

Re: Curve 8900 w/ EDGE system requirements problem

I looked over the material provided, but I am still not sure about the appworld...still not working and i can't seem to find a reason for it.

 

Thx for all the help so far, and I'll wait and see if anyone has any more ideas. 

Elite I
Posts: 6,343
Registered: ‎08-19-2008
My Device: 9800 - OS 6.0.0.246

Re: Curve 8900 w/ EDGE system requirements problem

Hmm, can you check what your default browser is set to? From within your browser hit the menu button and go into Options | General Properties
_______________________________________________________________________________________________________________
If someone has been helpful please consider giving them kudos by clicking the star to the left of their post.
Remember to resolve your thread by clicking Accepted Solution.