Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 12
Registered: ‎12-02-2010
My Device: 9780

Desktop Software crashes when clicking on "Configure Settings"



I am a Blackberry newbie having bought my first one yesterday: a Bold 9780.


I installed the Desktop Software that came with the CD on my notebook running Windows 7 Professional. When Desktop Software started up after installation, I immediately got an error message that said "Rim.Desktop.Autoupdate has stopped working" and it then tries to search for a solution which didn't work.


However, Desktop Software managed to open up nicely despite that problem. In the main window, I went through the setup procedure as prompted. But when I got to "Organizer" and click on "Configure Settings...", it will attempt to do so but will crash with a message saying "Black Berry Desktop Software has stopped working". I have tried it several times and had the same response.


I have spent close to 8 hours through the night reading through all the message and forums here and on other websites and have tried countless ideas: clean uninstall and reinstall, register DLL files, etc. but nothing works. I have even tried installing the previous version 5.0.1 which also has some issues with being unable to open device database or something like that.


Getting this desktop software working is very important as I need to import all my work contacts from Outlook 2007 to my new 9780.


I am really at my wits end and would appreciate any help.


Thanks so much.

Regular Contributor
Posts: 68
Registered: ‎12-04-2010
My Device: Bold 9000

Re: Desktop Software crashes when clicking on "Configure Settings"

hmm well it sounds like it could be a corrupt mapi profile to me, or a few other things, I would take a look at the following blackberry knowledge base articles.



Posts: 12
Registered: ‎12-02-2010
My Device: 9780

Re: Desktop Software crashes when clicking on "Configure Settings"

Hi, thanks for the reply. I tried the steps mentioned at the sites you linked but none of them helped at all. Upon further searching, I found a KB article mentioning that the crashing issue has been escalated with no solution as yet. It recommended that DM 5.0.1 be used instead.


So I did a clean uninstall of Desktop Software 6, downloaded DM 5.0.1 and went through the setup as documented. Did a sync and encountered a new problem. I check through and found some articles that recommended I try to narrow down the problem. I managed to sync my "task" and "notes" list on Outlook 7 with the BB Bold 9780 with no issues. But when I tried to sync the "Calendar" and "Address Book", it failed. Opening the log file, I discovered this error:


On 12/05/2010 21:59
One-way sync from Microsoft Outlook Contacts to Device Address Book
First System:             Device
Second System:            Microsoft Outlook
Second System File Name:  Address Book
Conflict Resolution:      Notify
Device Data Source:       "Default"
--> Failed to open device database!
Total Inputs From First System:  0
Field mapping used for translation:
   Device                            Microsoft Outlook
   First Name ---------------------- First Name
   Middle Name --------------------- Middle Name
   Last Name ----------------------- Last Name
   Title --------------------------- Job Title
   Company Name -------------------- Company Name
   Work Phone ---------------------- Business Telephone Number
   Work Phone 2 -------------------- Business Telephone Number 2
   Home Phone ---------------------- Home Telephone Number
   Home Phone 2 -------------------- Home Telephone Number 2
   Other Phone --------------------- Other Telephone Number
   Work Fax ------------------------ Business Fax Number
   Mobile Phone -------------------- Mobile Telephone Number
   PIN ----------------------------- User Defined String 1
   Pager --------------------------- Pager Number
   Internet Address1 --------------- Email1 Address
   Internet Address2 --------------- Email2 Address
   Internet Address3 --------------- Email3 Address
   Address1 ------------------------ Business Address Street 1
   Address2 ------------------------ Business Address Street 2
   City ---------------------------- Business Address City
   State/Prov ---------------------- Business Address State
   Zip/Postal Code ----------------- Business Address Postal Code
   Country ------------------------- Business Address Country
   Home Address1 ------------------- Home Address Street 1
   Home Address2 ------------------- Home Address Street 2
   Home City ----------------------- Home Address City
   Home State/Prov ----------------- Home Address State
   Home Zip/Postal Code ------------ Home Address Postal Code
   Home Country -------------------- Home Address Country
   Notes --------------------------- Body
   Interactive Handheld ------------ User Defined String 2
   1-way Pager --------------------- User Defined String 3
   Salutation ---------------------- Title
   Web Address --------------------- Web Page
   Direct Connect ------------------ Radio Telephone Number
   Categories ---------------------- Categories
   Picture ------------------------- Contact Photo
   Birthday ------------------------ Birthday
   Anniversary --------------------- Anniversary
   Nickname ------------------------ Nick Name
   Home Fax ------------------------ Home Fax Number
Internal Error #4238.
Translation Canceled!
Again I googled it and came up with nothing that worked. Stuff I tried:
1) Cleared the database using the "Advanced" function in "Backup and Restore" but that didn't help either.
2) Deleted the "IntelliSync" folder and re-configured the sync and tried it again. Nada.
3) Created a new empty profile on Outlook 2007 with no calendar or address book entries just in case there are some corrupted entries there, reconfigured DM 5.0.1 to sync from that and overwrite all data on my Bold 9780 and that didn't work either.
4) To be sure, I even tried to sync from Yahoo. And those DM did successfully log in, the same error as above pop up.
I would hazard a guess that DM 5.0.1 is not able to open the Bold 9870's database. Not sure why.
I think I should mention at this point that I am using Windows 7 Pro Edition and Outlook 2007. I am not using any enterprise nor any wireless sync. All I am trying to do is to get my address book and calendar entries onto that DARN Bold 9780 with the supplied cable.
I am thinking that maybe DM 5.0.1 may not be able to access the database on my Bold because it's running OS6.
Any ideas?
Posts: 12
Registered: ‎12-02-2010
My Device: 9780

Re: Desktop Software crashes when clicking on "Configure Settings"

[ Edited ]



Software: Desktop Software 6

OS: Windows 7 Professional 32 bit


Ok, as I stated above, "Rim.Desktop.Autoupdate" was crashing whenever I launched "Desktop Software" version 6. On top of that, whenever I clicked on the [Configure settings...] button on "Organizer" in "Desktop Software", it will run for a while before the whole program crashes. And even if I were to close the program without doing anything, it too will crash.


After combing through countless forums and stuff, I checked out the Desktop.log file and found an interesting entry:


Date|Log Level|Thread ID|Module ID|Log ID|Message [2010-12-09 04:42:39.308]
04:42:39.326|INFO |1|Rim.Desktop.Shell|1|Application Started
04:42:39.338|INFO |1|Rim.Desktop.Shell|2|Rim.Desktop.exe Version:
04:42:39.338|INFO |1|Rim.Desktop.Shell|2|OS Version: Vista [Microsoft Windows NT 6.1.7600.0]
04:42:39.338|INFO |1|Rim.Desktop.Shell|2|CLR Version: 2.0.50727.4952
04:42:39.343|ERROR|1|Rim.Desktop.Common|0|Failed to read registry key.
System.Security.SecurityException: Requested registry access is not allowed.
at System.ThrowHelper.ThrowSecurityException(ExceptionResource resource)
at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
at Microsoft.Win32.RegistryKey.OpenSubKey(String name)
at Rim.Desktop.Common.Utils.Utilities.GetPathFromRegex(String key, String keyname, RegistryKey regkey)


I took up someone's suggestion and tried to take ownership and permission of HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. But that only screwed up my network connections completely. But thanks to Windows 7 "Restore this computer to an earlier point in time" utility in Control Panel, I was able to reverse the damage.


Then it occurred to me to try to take ownership and permission of "HKEY_CURRENT_USER\ SOFTWARE\Research In Motion" and "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion".


Taking ownership of the former went well but trying to do so for the latter threw up the error message "Registry Editor cannot set Owner on the key currently selected, or some of its subkeys." So I decided to take ownership of each individual sub-keys in "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion" to see where the problem was.


I finally manage to narrow it down to "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\AppLoader".


But of course the challenge now was to figure out how to take ownership of this sub-key. I found this site http://www.mydigitallife.info/2009/09/02/grant-read-write-full-control-permissions-on-registry-keys-... and followed the instructions there.


After that, I tried launching Desktop Software 6 again. This time round, it worked.


"Rim.Desktop.Autoupdate" didn't crash and neither did Desktop Software when I click on [Configure settings...] or tried to exit the program.


The steps to edit the registry.


1) Make a back up of the registry file or just make sure that Windows 7's restore program has the latest image of your system


2) Click on the Windows start button on the lower left corner of your task bar. That's the one with the Windows logo on it


3) In the space above it with the magnifying glass on its left, type "regedit" (without the quotation marks of course) and hit [Enter].


4) Look for "HKEY_LOCAL_MACHINE", click on it and scroll down to look for "SOFTWARE". Click on that and then look for "Research In Motion".


5) Within that sub-key, you should see "AppLoader", "Blackberry", "Blackberry Transcoder", "Common" and "DesktopAutoUpdate".


For the steps on how to take ownership, please refer to http://www.mydigitallife.info/2009/09/02/grant-read-write-full-control-permissions-on-registry-keys-... (I am too lazy to type it out in full and I am not sure if I will be infringing on their copyright if I just copied and pasted)


Oh, and please remember to make sure your userID or the user group you belong to has Full Control over those sub-keys.