Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 3
Registered: ‎02-15-2011
My Device: Not Specified

Re: Desktop Software crashes

I download version 6.0.1.18 and installed totally brand new (no update) in a computer without any BB software and works fine... perhaps is a problem between registers due update.

 

what about .NET 2 or 3.5...??

 

New Member
Posts: 1
Registered: ‎04-16-2011
My Device: curve 8900
My Carrier: mobistar

Re: Desktop Software crashes

Hi,

I had the same problem that you had.

I did clean uninstall and then reinstalled it, which didn't changed anything... looking in the crash report (you can find it in your documents and settings folder under user\application data) I saw that there was a problem with the "Rim.Desktop.Services.PolicyManager.dll" (dll you can find in the modules subfolder of your blackberry desktop manager folder).  So I renamed it as "BACKRim.Desktop.Services.PolicyManager.dll" and it seemed to solve the problem, now the manager can run on my system...


Hope it will help !

New Contributor
Posts: 8
Registered: ‎04-24-2011
My Device: Playbook; 9780
My Carrier: Logistics manager

Re: Desktop Software crashes

Thank you very much mate!!!
Your solution works great!!!
Highlighted
New Contributor
Posts: 6
Registered: ‎05-08-2011
My Device: Storm
My Carrier: Telus

Re: Desktop Software crashes

So here's how I fixed my issue.

 

Delete the Rim.Desktop.exception.log located here:

 

C:\Documents and Settings\[USERNAME]\Application Data

 

Run the application, it will crash with the error message above and create a new Rim.Desktop.exception.log file. Open it in notepad and look through it.

 

In my case the exception was this.

 

Exception message is: The current build operation (build key Build Key[Rim.Desktop.Shell.MyBlackBerryApplication, null]) failed: Could not load file or assembly 'Rim.Desktop.Services.PolicyManager, Version=6.0.2.44, Culture=neutral, PublicKeyToken=null' or one of its dependencies

 

I followed the suggestion of renaming the file C:\Program Files\Research In Motion\BlackBerry Desktop\Modules\Rim.Desktop.Services.PolicyManger.dll to Rim.Desktop.Services.PolicyManger.dll.old

 

I then tried to lauch the application and it crashed, you must do this! renaming it back without this step will not work. Then I went back and renamed the dll file back to it's original name Rim.Desktop.Services.PolicyManger.dll and sure enough the application worked.

 

Must be some messed up reference somewhere, it's stupid and RIM should figure this out before releasing updates. Obviously your issue may be different but the exception.log file should point you in the right direction.