Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 2
Registered: ‎12-05-2008
My Device: Torch 9800
My Carrier: AT&T

Dissappointed - WILL SOMEONE AT RIM PLEASE ADMIT that the rcp5.us.blackberry certificate expiration is A MAJOR PROBLEM

I am a career long devotee, defender and advocate of RIM. Conservatively, I have easily spent more $5,000 over the last 7-8 years on RIM products because I believed in the company and its product. I pounded my chest when RIM refused to compromise their security because certain oil-rich countries wanted to have surveillance capabilities - I told people, RIM is above the rest, that's what RIM is all about !

 

(Enter the rcp5.us.blackberry certificate expiration problem)


I must say that now, as the mystery grows surrounding when a patch or fix will be pushed or published to this fix this problem (curious is the lack of any willingness to admit this is A MAJOR PROBLEM!) along with not even a hint that this might be affecting more than an unfortunate few (my guess is that its more like thousands of Torch OS.6.0 users who are "down" because of this lovely certificate expiration and associated tech glitch it causes), and we aren't even seeing any DISTINCT AND IMMEDIATE URGENCY from RIM regarding addressing a problem that is costing hundreds, maybe thousands, of business and sales professionals, to lose thousands of dollars in the form of lost productivity - and Yes, very soon people will say (in days not weeks) "well maybe its finally time to give that HTC 4g Droid or that Apple i4 a try". Where is the "CRACK RESPONSE WE HAVE SEEN BEFORE" with other big problems. (and yes, I am referring to the rcp5.us.blackberry certificate expiration problem and its rendering of my blackberry into nothing much more than a $9.99 Trac Fone  - No BIS data, No BIS email, etc), Ironic, the corporate store folks arent even aware of any problem, and my regional authorized repair center looked at me as if I had gone insane, instead they decided to check the computer to see if our corporate account was up to date with its payment.

 

RIM, AT&T, etc - PLEASE ADDRESS AND FIX THIS PROBLEM SOON, IN A TENUOUS ECONOMY, AND AN ULTRA DYNAMIC MARKETPLACE, WITH COMPETING PRODUCTS GETTING BETTER AND BETTER, YOU OWE IT TO YOUR SHAREHOLDERS AND CUSTOMERS.

 

Sincerely,

Jon

 

 

 

Yes I have "Capture - It" on my Torch
Forums Veteran I
Posts: 2,119
Registered: ‎08-07-2010
My Device: Bold 9900, Playbook , HS-700 headset
My Carrier: Rogers

Re: Dissappointed - WILL SOMEONE AT RIM PLEASE ADMIT that the rcp5.us.blackberry certificate expiration is A MAJOR PROBLEM

Hiya!

 Well I havent read all the details as to what it entails... But v6.0.0.695 will be available from AT&T shortly and I believe there is already a leak for it. So it very well could already be fixed.

 If you would be so kind as to let us know if it has been after afore mentioned update. Im sure many would appreciate it.

-------------------------------------------------------------------------------------
1). Please thank those who help you by clicking the Like Button beside the 'Reply' button.
2). If your issue has been solved, please resolve it by marking "Accept as Solution" on the correct post!
3). Remember to have fun! We are all in this together!
4). Follow me on Follow Raelic1337 on Twitter

New Contributor
Posts: 2
Registered: ‎12-05-2008
My Device: Torch 9800
My Carrier: AT&T

Re: Dissappointed - WILL SOMEONE AT RIM PLEASE ADMIT that the rcp5.us.blackberry certificate expiration is A MAJOR PROBLEM

No I havent performed the OS upgrade to the newest version released yesterday or today as I havent seen any evidence that it will fix the rcp5.us.blackberry certificate issue. Have you read that it addresses this problem ??? The only thing I have seen thus far that was recommended is full wipe work around, and I havent seen the moderators truly endorse it as a way to fix this problem.

Thanks for asking and have a great evening.

 

Sorry for the rant, but I have had clients hammering me for lack of response during the 2 days I have been down.

 

Jon

Yes I have "Capture - It" on my Torch
Forums Veteran I
Posts: 2,119
Registered: ‎08-07-2010
My Device: Bold 9900, Playbook , HS-700 headset
My Carrier: Rogers

Re: Dissappointed - WILL SOMEONE AT RIM PLEASE ADMIT that the rcp5.us.blackberry certificate expiration is A MAJOR PROBLEM

Well the only way to really know for sure is to try it.

 

Aside from that, the only work around is the wipe.

 

This isnt just affecting the Torch so its hard to say.

-------------------------------------------------------------------------------------
1). Please thank those who help you by clicking the Like Button beside the 'Reply' button.
2). If your issue has been solved, please resolve it by marking "Accept as Solution" on the correct post!
3). Remember to have fun! We are all in this together!
4). Follow me on Follow Raelic1337 on Twitter

Guru III
Posts: 32,199
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Dissappointed - WILL SOMEONE AT RIM PLEASE ADMIT that the rcp5.us.blackberry certificate expiration is A MAJOR PROBLEM

There is a thread on this issue already. There are a few fixes in there for it. I have also heard from a few that the OS upgrade fixes it since it will get new certs during the install or first boot when you get service books. I have 20 of these to push out in the next week and they will all be on the new OS. I have been on it for over a week now it it fixes all the issues I have seen on it.

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V