Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 22
Registered: ‎11-07-2008
My Device: Not Specified

Documents to Go "Pending Dialog" message


I have an End User who attempted to open up an excel spreadsheet (.xls extension) in Docs to Go. The doc failed to open, but now, when they try to open up a new/different doc, they're getting an “The document could not be opened because there is a pending dialog in Documents to go. Please close the dialog and try again.” message, and they are unable to open any file/doc.


The EU has a BB 9650 Bold running


We've pulled the battery with no luck.


We tried hitting the BB/Menu key and selecting “switch application”. to see if either Docs to Go or the Doc itself is and option,  then select it and attempt to close, but  once they select DtG, the device hangs.


Anyone have any ideas on how to resolve this?

Posts: 409
Registered: ‎06-13-2011
My Device: Z10, Playbook
My Carrier: Econet

Re: Documents to Go "Pending Dialog" message

Have you tried doing a hard reset? Can you open other file (word, spreadsheet etc)? How about putting back the file which couldn't open in the folder it was and try opening it?
Twitter: @IAmBenGiey | Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.

Try my apps:
The Ultimate Currency Converter and T2G - BloGFeed
Posts: 22
Registered: ‎11-07-2008
My Device: Not Specified

Re: Documents to Go "Pending Dialog" message

@ Ben1107


Thanks for the reply.  I received incorrect info from the EU, as they indicated they had done a hard reset (before I posted here), but in fact, they had not, instead they had just powered off the BB.


Once we got that clear, I had them do a battery pull and that did resolve the issue.

New Member
Posts: 1
Registered: ‎03-03-2013
My Device: 9700 visafone
My Carrier: 60,000

Re: Documents to Go "Pending Dialog" message

I have same issue but mine hasnt worked yet