Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 4
Registered: ‎03-20-2010
My Device: Blackberry Bold 9700
My Carrier: T-Mobile

Re: EMAIL: Your device had a problem connecting to the server?

I had the same problem. I patiently attempted the solutions one after the other of what people provided but my blackberry would not let me install another email address. I kept getting the "Cannot connect to server" response. I upgraded to version 6.0, and still didn't solve it. I tried the battery removal solution and the reboot solution. Tried to play with all sorts of stuff on my phone. After three hours, the one that worked for me, and quickly enough, was the removal of Enterprise Messenger. Once I deleted Enterprise Messenger using Desktop Manager on my laptop, then I could get access and install more email accounts. Good luck to those still struggling.

New Member
Posts: 1
Registered: ‎01-15-2012
My Device: Bold 9900
My Carrier: T-Mobile

Re: EMAIL: Your device had a problem connecting to the server?

When setting up email and you get the error "Update Failed" or "Your device had a problem connecting to the server" ...you have two options:

 

1. Just use the Carrier BIS online website. (You will need the device imei or pin.)

 

2. Call the carrier and they can do it from their end.

 

This will solve the issue.

 

Thanks,

Brent

New Member
Posts: 1
Registered: ‎01-16-2012
My Device: 8520
My Carrier: BSNL

Re: EMAIL: Your device had a problem connecting to the server?

your device had problem connecting to server blackberry - Can you help me with settings

haq
New Member
Posts: 2
Registered: ‎08-20-2012
My Device: blackberry9105
My Carrier: o2

Re: EMAIL: Your device had a problem connecting to the server?

I have not received an email to my blackberry for 3 days and wondered if something went wrong.

When I run Setup > Email settings.

Its starts to load up something then comes up with an error of 'Your device had a problem connecting to the server'

Does this just mean I'm not in a area with a connection? Any help?
haq
New Member
Posts: 2
Registered: ‎08-20-2012
My Device: blackberry9105
My Carrier: o2

Re: EMAIL: Your device had a problem connecting to the server?

I have not received an email to my blackberry for 3 days and wondered if something went wrong.

 

When I run Setup > Email settings.

 

Its starts to load up something then comes up with an error of 'Your device had a problem connecting to the server'

 

Does this just mean I'm not in a area with a connection? Any help?

Hall of Famer III
Posts: 58,158
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: EMAIL: Your device had a problem connecting to the server?


haq wrote:

I have not received an email to my blackberry for 3 days and wondered if something went wrong.

 

When I run Setup > Email settings.

 

Its starts to load up something then comes up with an error of 'Your device had a problem connecting to the server'

 

Does this just mean I'm not in a area with a connection? Any help?


Hi and Welcome to the Community!

 

Please read this thread and try what is already posted, especially message 15.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Member
Posts: 2
Registered: ‎12-02-2012
My Device: Bold
My Carrier: Vodafone

Re: EMAIL: Your device had a problem connecting to the server?

Hi, Just joined this forum because of this same problem.  I have tried the first part of post 15. (The HRT bit)  How long should it take for the BB message to come through?

 

Thanks

Hall of Famer III
Posts: 58,158
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: EMAIL: Your device had a problem connecting to the server?


Dauphin1960 wrote:

Hi, Just joined this forum because of this same problem.  I have tried the first part of post 15. (The HRT bit)  How long should it take for the BB message to come through?

 

Thanks


Hi and Welcome to the Community!

 

Not very long...if within an hour it does not arrive, then you'd stop and contact your mobile service provider for formal support. Something is not right with your BBs connection to your mobile service providers data network...and only they can look "behind the scenes" to see what is wrong.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Member
Posts: 2
Registered: ‎12-02-2012
My Device: Bold
My Carrier: Vodafone

Re: EMAIL: Your device had a problem connecting to the server?

Thanks for that.  I spoke to Vodafone and it turns out they had stopped the Blackberry service when making a change to my account.  If only I could invoice them for my time!

 

Thanks again for the quick response.  All sorted now.

Hall of Famer III
Posts: 58,158
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: EMAIL: Your device had a problem connecting to the server?

Excellent! You are most welcome indeed!

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................