Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Contributor
Posts: 2
Registered: ‎07-04-2008
My Device: Not Specified


HELP! For some strange reason, the flash on my camera (8100 pearl) won't turn off. It remains on.
Elite II
Posts: 9,321
Registered: ‎04-01-2008
My Device: Torch 9800
My Carrier: grameenphone


Have you tried soft reset (pulling the battery out for 30sec.)? If that doen't solve your problem then you need to contcat any service center authorized RIM. It might be some hardware issue. Another resolution could be reinstalling the OS again. But if the hardware is damaged then reinstalling OS will not help.

If your query is resolved then please click on Accept as Solution

Click on the LIKE on the bottom right if the post deserves credit

New Member
Posts: 1
Registered: ‎07-14-2008
My Device: Not Specified


 The same thing is happening to me-Its gotton to the point where my battery is so drained, it wont even partially charge!

I've already done the reset--nothing; I've tried to physically take out the flash, but cannot find anything to undo those itsy-bitsy screws. Can I take it somewhere to solve this problem??! I'm getting a bit desperate; anybody have any suggestions?