Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 5
Registered: ‎11-30-2009
My Device: Not Specified

Facebook won't install; device not supported?

Hi all,

I just got my first blackberry (curve 8330) yesterday. On my plan I have unlimited use of the Facebook app (although I'm told I need v1.6 to avoid data charges).

I initially tried downloading the facebook app from the blackberry website using my laptop. However, when I had my curve connected via USB it said that my device was unsupported for use with the Facebook app. I'm pretty sure it is compatible with the 8330, is it not? Anyway any help would be greatly appreciated! I don't want to be paying for facebook use if I can't even use it.

 

BTW my curve is running v4.5.0.169 (Platform 3.4.051), I'm sure this is the most recent available update.

 

Thanks again!!!

Posts: 95,161
Likes: 24,501
Solutions: 6,378
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Facebook won't install; device not supported?

1. Do you have THE BlackBerry Data Plan with your carrier? That is what's needed.

 

2. .169 is not the latest OS release for the 8330, I think .175 is the latest, although .169 could be latest from your carrier.

 

 



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
Posts: 5
Registered: ‎11-30-2009
My Device: Not Specified

Re: Facebook won't install; device not supported?

Ok, I tried updating using the v4.5 update link through the blackberry website, but the version that came up in the desktop manager was 4.5.0.169 which is already on my phone. Should I be downgrading to a different version to make it work? Although 4.5.0.169 was the OS on the device when I got it from Telus, so I would think it should work.

Posts: 95,161
Likes: 24,501
Solutions: 6,378
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: Facebook won't install; device not supported?

Could you answer the first question?



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
Posts: 5
Registered: ‎11-30-2009
My Device: Not Specified

Re: Facebook won't install; device not supported?

Oops, sorry.

I have the Clear Choice Blackberry Social Plan from Telus. It does not come with data per se, but included is "Unlimited Facebook, Myspace, BlackBerry Messenger, and Windows Live Messenger".

Also, for this plan (in regards to the social networking features mentioned above) : "Feature does not include: access to the Internet, including without limitation through the TELUS WAP gateway the ability to send or receive email; and access to any other social networking service or instant messaging service (including, without limitation, to any web based version of the included social networking services or instant messaging services). This package cannot be combined with any other data plan and is only available for BlackBerry® smartphones."

So that would seem that I need to access Facebook through the BlackBerry app, not through the website. Therefore I somehow need to get the app onto my phone.

 

Thanks for your help so far JSanders!

New Contributor
Posts: 5
Registered: ‎11-30-2009
My Device: Not Specified

Re: Facebook won't install; device not supported?

Can anyone help me at all?

New Member
Posts: 1
Registered: ‎01-24-2010
My Device: blackberry storm
My Carrier: telus

Re: Facebook won't install; device not supported?

Hey just wondering did you ever find a solution to your facebook problem? I have the Telus blackberry social plan and am unable to download facebook! Any help you can give me would be appreciated thanks!

New Member
Posts: 1
Registered: ‎05-13-2010
My Device: Curve 2
My Carrier: Telus

Re: Facebook won't install; device not supported?

 

I am getting the same error msg;

 

Notice: Sorry, your device does not meet the system requirements that are needed to support Facebook.

 

 

 

Has there been any update with anyone else having this issue?