Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 3
Registered: ‎11-25-2010
My Device: BlackBerry Bold 9780
My Carrier: Vodafone Australia
Accepted Solution

Far East Language and other Support questions for Bold 9780 - please provide feedback!

Hi there,

 

Here are my specs for your info:

BB Bold 9780 (bought 3 days ago - unlocked to any carriers)

My carrier - Vodafone (Australia) - BIS activated

Computer - Macbook Pro

 

 

After having researched on the web for the whole day, I found out that Far-Eastern languages is not yet available on the Bold 9780.

 

I understand that I have to d/l a far-east language pack from the carrier (mine is Vodafone Australia), in order to read and input Chinese, Japanese or Korean language on the BB. This is extremely frustrating, and I feel like we're going backwards in the realm of smart phones - globalisation has to have been a major consideration for many keen smart phone users out there.

 

I have some questions, I hope you guys can provide some feedback:

 

1. What kind of time frame are we talking to have the language support for the Far-East region? I never would have bought the new BB (probably would have gone for the 9700) if I knew that Far-east languages would not be available on the newest BB !!?? I know that it's provided by the carriers, but surely RIM provides the build?

 

2. As I'm a newbie (i come from 2.5 years of iPhones), I don't get the concept (nor is it documented all that clearly) of having a OS6 and Device software 5?? what the heck is the difference, or are they just the same thing??? having thought about it, maybe it is... but why is OS6 already released, yet I still see "latest and greatest Device Software 5" all over the BB website? someone please help me understand this.

 

3. Is there ANY way that I can load a previous version of the device software (Vodafone provides a Far-east pack for BB Bold 9700)? I've tried many times, after having run and unpacked the file into the Desktop manager, the Device Software does not even appear on my Desktop Manager (v6). is this because the Desktop manager detects the version of my phone and disallows the vodafone device software for 9700 appearing in the list of applications to load? or should it?

 

4. on my MAC, I can't install the App world plug-in - it says that it's not available on a Mac... how are mac users supposed to make use of desktop based App World access? I know we're not a majority, but this is obsurd - having said this, I'm not unreasonable, I can live with this.

 

5. Do BB have free phone technical support in Australia? again I can live with no having one, but I feel this is also unreasonable.

 

 

please dont get me wrong - I might come across whining - but I desparately want my new device to work... I like so many things about the BB, and having taken the big step from the iphone, I'm finding a lot of things that were never mentioned on crackberry, or any other BB fanboy sites...

 

Thank you in advance, look forward to your feedback!

 

PBM

 

 

 

 

Hall of Famer III
Posts: 57,612
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Far East Language and other Support questions for Bold 9780 - please provide feedback!

[ Edited ]

Hello,

 

OK...first things first...these forums are not a communication channel to/from RIM. Rather, these forums are a user-to-user support community. RIM provides zero front line support...all support is fronted by the carriers and authorized resellers, who have the ability to escalate into RIM if necessary.

 

OK...with that out of the way, let's proceed:

 

 


pbmpbm wrote:

 

1. What kind of time frame are we talking to have the language support for the Far-East region? I never would have bought the new BB (probably would have gone for the 9700) if I knew that Far-east languages would not be available on the newest BB !!?? I know that it's provided by the carriers, but surely RIM provides the build?

 


Impossible for anyone here to know...or, if they do know, against the TOS of this site to reveal.

 

 

Of further interest is the fact that, via the official download portal for your stated carrier, your model BB is not even listed:

 

 


pbmpbm wrote:

 

2. As I'm a newbie (i come from 2.5 years of iPhones), I don't get the concept (nor is it documented all that clearly) of having a OS6 and Device software 5?? what the heck is the difference, or are they just the same thing??? having thought about it, maybe it is... but why is OS6 already released, yet I still see "latest and greatest Device Software 5" all over the BB website? someone please help me understand this.


 

OS 6 is the next generation of BB OS's (and there is even chatter about OS7 "out there"). The most recent version supported by your carrier is available via their download portal linked above (albeit with your model number conspicuously absent). OS 6 has been released for certain model BBs only (I do not know if it has been released for your stated model BB). But, OS's are never released by RIM to the public...rather, only to the carriers who must certify and adopt an OS and then release it to their users. The reason for this falls back to the start of this post...they (the carriers) are responsible for all support...hence, they reserve the right to adopt or reject an OS that RIM has released to them.

 

 


pbmpbm wrote:

 

3. Is there ANY way that I can load a previous version of the device software (Vodafone provides a Far-east pack for BB Bold 9700)? I've tried many times, after having run and unpacked the file into the Desktop manager, the Device Software does not even appear on my Desktop Manager (v6). is this because the Desktop manager detects the version of my phone and disallows the vodafone device software for 9700 appearing in the list of applications to load? or should it?

 


 

You can use ONLY an OS package that is for your specific BB model number...nothing else will work. A 9700 is not a 9780, so the OS packages are not interchangeable. The best procedure I know for loading (upgrading, downgrading, reloading) an OS package is here:

Note that this works only on PC's...not MACs. But, you are not limited, with this procedure, to only your carriers OS packages. You are free to use any OS package from any carrier as long as it is for your specific BB model number. If you choose to do so, then simply insert, between steps 1 and 2, the deletion, on your PC, of a file named VENDOR.XML.

 

 


pbmpbm wrote:

 

5. Do BB have free phone technical support in Australia? again I can live with no having one, but I feel this is also unreasonable.

 

 


I refer you back to the beginning...all support starts with your carrier.

 

Good luck and let us know!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 3
Registered: ‎11-25-2010
My Device: BlackBerry Bold 9780
My Carrier: Vodafone Australia

Re: Far East Language and other Support questions for Bold 9780 - please provide feedback!

Thanks for clarifying all that for me - it's been a massive and daunting task to try and understand how the BB works.... I think I'm almost there Smiley Happy

 

Your answer is much appreciated, thanks again.

 

pbm

 

New Contributor
Posts: 2
Registered: ‎02-19-2011
My Device: Not Specified

Re: Far East Language and other Support questions for Bold 9780 - please provide feedback!

Which website did you go to get that info about os7
New Contributor
Posts: 2
Registered: ‎02-19-2011
My Device: Not Specified

Re: Far East Language and other Support questions for Bold 9780 - please provide feedback!

I aldo hope that they will make it less hardware intensive so that it can work on previous models... Although I that its not likely