Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 3
Registered: ‎09-04-2013
My Device: Bold 9930
My Carrier: TMobile

GIFs not showing up

I have a Z10 (STL1003 / 10.1.0.4633) and when I try to send GIFs to myself (legacy Bold) or my friend via BBM, they don't show up.  They only come through as a picture.  The Bold's we're running are:

 

9930 v7.1.0.991

9900 v7.1.0.746

 

Even though we choose "request higher quality", the GIFs still only display as static pictures.  Is there a setting or something that needs to be set up in order for the GIFs to be displayed correctly (animated)?  Note, that I'm referring to GIFs that are sent and received, NOT BBM avatars.  

Retired
Posts: 134
Registered: ‎05-16-2013
My Device: Q10/9900/9790
My Carrier: Rogers

Re: GIFs not showing up

Hello deehaliman

Welcome to the BlackBerry Support Community Forums.

 

Sorry to hear you are having an issue with viewing animated GIFs on your BlackBerry Bold 9900 and 9930.

 

Can you please confirm if you have tested with other animated GIF images? (does this happen to all of the GIF images you have tested)?

 

Does the BlackBerry Z10 smartphone play the animated GIF?

 

The BlackBerry 9900 and 9930 smartphones do support the GIF image format. However there maybe certain GIF images the device may not be able to display correctly.

 

Please reference the BlackBerry Supported Media Types on BlackBerry Smartphones reference guide


Goose947


 


Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp


Be sure to click Like! for those who have helped you.

Click Accept as Solution for posts that have solved your issue(s)!


New Contributor
Posts: 3
Registered: ‎09-04-2013
My Device: Bold 9930
My Carrier: TMobile

Re: GIFs not showing up

Goose947,

 

I can confirm that I have tested with other animated GIF images.  Every single one that I tested with do not play on the two Bolds that I listed.  The GIFs work perfectly on my Z10, as well as other friends' Z10 and Q10.  I've even tested with another friend who is running a legacy OS6 phone and they work perfectly on there as well.

 

After a lot of testing & trouble shooting, I managed to get the GIFs to work for other friends.  Here are the steps that I took:

 

1. Save off any GIF that was attached to an email
2. BBM the contact and attach the GIF
3. Recipient has to then "Request Higher Quality Image" in order for the GIF to be sent

In the past, I was able to open the GIF that was attached to an email and click on "Share". I'd choose a BBM contact and just send it to them (BB10 or legacy device), without saving anything on my phone. The GIF would be sent and there wouldn't be a need for requesting higher quality images, nor would I have to save off anything to my phone.

 

BUT...for the two Bolds that I mentioned, it doesn't work no matter what I try.  The 9930 is on Verizon, the 9900 is on Telus, and my Z10 is running on TMobile.

 

I'm running a stock Z10: STL100-3

Software release: 10.1.0.4200

OS Version : 10.1.0.4780

Retired
Posts: 134
Registered: ‎05-16-2013
My Device: Q10/9900/9790
My Carrier: Rogers

Re: GIFs not showing up

In order to show an animated GIF in the BlackBerry Messenger Application it needs to meet the following requirements:

 

1. Verify that you're using a .gif file that is not larger than 32 KB.
2. Verify that the picture is square (the height and width, in pixels, are the same).
3. Verify that the dimensions of the picture are less than 333 x 333 pixels.
4. If necessary, you can try editing the file using a computer to adjust the size or dimensions.

 

Attempt to send an animated GIF that is "icon" sized and extremely basic as a test.

 

I look forward to your reply.


Goose947


 


Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp


Be sure to click Like! for those who have helped you.

Click Accept as Solution for posts that have solved your issue(s)!


New Contributor
Posts: 3
Registered: ‎09-04-2013
My Device: Bold 9930
My Carrier: TMobile

Re: GIFs not showing up

Goose947,

 

I don't think that's the issue.  I'm aware of those limitations IF you want to set a GIF as your BBM avator.  However, that's not what I'm trying to do.  The issue is they're not viewable on the 2 Bolds (9930 & 9900).

 

At the moment, they are viewable on Z10s and Q10s but only via the steps I outlined in my previous post.  The user has to request a higher quality image.  The same applies for other legacy BlackBerry devices.  I've tested with by sending to a friend who is running an OS6 legacy device and if they request a higher quality image, the GIF is animated and they can view it.  Please note that the GIFs range in size from 200 kb to about 1200 kb.

 

Again, a couple weeks ago, I was able to open the GIFs in an email and click on "Share" and send them directly to my BBM contacts, without a need for them to request a higher quality image.  But now I cannot do that.  I have to save them off and then send them as an attachment in BBM.  They then have to request a higher quality image in order to see the animated GIF.  Otherwise, they're only displayed as a static picture.  However, with the 2 Bolds I've listed, they GIFs are received as a static picture and they cannot view the animated GIFs regardless of what we try.

Developer
Posts: 45
Registered: ‎08-29-2013
My Device: Blackberry curve-9360 and Blackberry bold-9860
My Carrier: Company

Re: GIFs not showing up

I have the image with Dimension 250x250, Size 25 kb. But it not work properly for me please help.

Thanks in advance.