Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
p95
New Member
Posts: 2
Registered: ‎08-16-2012
My Device: BlackBerry Bold 9780
My Carrier: Fido

☆ [HELP] BlackBerry 9780 Wifi Problem ☆

Hello, I've had my BlackBerry Bold 9780 for about 4 months and have recently had problems regarding my Wi-Fi connection. I do not have a PIN or enterprise activation, I just bought the blackberry, unlocked it and used it, and it's been working fine up until these past 2 weeks. So, the problem is that I connect to my wifi, the bars are highlighted as normal, but as soon as I go to open my Twitter app or Facebook app, I get a big message that says "You are currently on a service plan that does not support this application. If you want to use this application, please connect to a Wi-Fi network or contact your service provider to upgrade your data plan."

 

It says "... please connect to a Wi-Fi network ..." and I don't understand that because I AM connected and this never happend before but lately its been bugging. The weirdest part is that my App World works, my browser SOMETIMES, but the Twitter/Facebook app has been completely dead these past few days. I doubt this is a problem with my Wi-Fi connection because it says its connected, the bars all light up, and App World works. I don't know what to do, I've reset my blackberry to factory settings and still the same problem. 

 

Feel free to send feedback

 

Thank you.

Forums Advisor III
Posts: 1,077
Registered: ‎04-23-2012
My Device: 9900
My Carrier: Bharti-Airtel

Re: ☆ [HELP] BlackBerry 9780 Wifi Problem ☆

Hi P95,

 

Thanks for your Post...!!

 

Please turn off mobile network during Wi-Fi access then observe, also try by re-adding Wi-Fi profile.

 

 

New Member
Posts: 1
Registered: ‎09-20-2012
My Device: 9810
My Carrier: ATT

Re: ☆ [HELP] BlackBerry 9780 Wifi Problem ☆

did you get any response whatsoever on your problem?    

I just got a BB9780 Bold (9/2012)  and Im having the same problem.  What I discovered is that the WIFI connection is failing and doesnt seem to work  when running on battery power alone.  It is working when I connect the power adapater to the unit.     I was thinking if the WIFI connection is eating up so much of the battery power so as to lose or prevent connection.  I bought a new battery just check if my current battery is deffective,  but it's the same issue.   Try  using the wifi while connected to the power adapter and see.  Let me know.  thanks