Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎12-10-2012
My Device: blackberry bold 9700
My Carrier: Tmobile

HELP No Internet, but connected to WIFI

I recently upgraded my bold 9700 OS6 to bundle 3049. I know I was a little over due, but it's been a while since I connected it to my PC.


New OS6 runs just as smooth as i've read on the forums and internet, however now when I connect to WIFI it's useless, I just get a message when going through the browser:


"Unable to connect to the Internet, please try again later. If the problem persists please contact your service provider."


I can only assume that with this update, something changed from the previous OS6 version that doesn't allow me to connect to WIFI anymore without a data plan.


However i've read that this should not be the case.


Has anyone experienced this? or know how to fix it?


I have tried to reload the OS multiple times and had same issue each time. I have an original tmobile phone on the tmobile network and any help would be great.





Posts: 2,649
Registered: ‎04-01-2008
My Device: 9500, 8110, 8700, 8220, 9100, 9800, 9810, Z10

Re: HELP No Internet, but connected to WIFI

Hello slick9456, 


Welcome to the forums. 


Do you currently have a data plan through your mobile network provider? In some cases in order to use WI-Fi you still require a data plan. Have a look at the below article for more information. 


Services that are available over a Wi-Fi connection


Please read the Note section at the bottom of the article for additional information. 


Hope this helps. Have a good day. 



Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!