Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 9
Registered: ‎11-04-2012
My Device: Bold 9900/9780
My Carrier: Dialog Axiata

HS-700 Upgrade Problem


I tried upgrading the firmware on my HS-700 using the updater downloaded from the following page:




The first part of the upgrade went ok, where the language pack was rewritten.


The second part failed with instructions to restart the upgrade, and when I close this instructions popup, the upgrader showed a message "Download failed" just above the progressbar.  I have repeated the upgrade, with the same result.


Now the headset has lost voice prompts.  It is working, I can make calls etc, but I don't get any feedback nor instructions.


I noticed several posts about the same issue, and warnings not to do any upgrades, but it was too late... :-(

Guru III
Posts: 32,189
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: HS-700 Upgrade Problem

[ Edited ]

there is a thread where some one did get this fixed.


found it



Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

New Contributor
Posts: 9
Registered: ‎11-04-2012
My Device: Bold 9900/9780
My Carrier: Dialog Axiata

Re: HS-700 Upgrade Problem

Thanks for the reply.


I've seen that thread, and few others.  A Google search for HS-700 upgrade problems always brings those threads as the first search results.


The proposed solution requires a patched upgrader, but that file is no longer there.  I know how to change a binary file, but the thread doesn't have sufficient details about the two bytes to change when patching the file.


Perhaps my problem may be different, because I can't get the upgrader to finish.  It always fails at the second phase with a popup that says the upgrade fails, and when I close the popup, the upgrader shows an empty progressbar with the message like "Download failed".