Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Hall of Famer III
Posts: 57,533
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: I can`t update bold 9700 to OS6


johnxspider wrote:
i did what you said i went to kb10144 i followed that to do the update, the thing is i feel stupid cause i think now i could update it to 6 but cause i was afraid it was not going to work i pressed 5.. hurray.. -_-

You can actually install any compatible OS (same exact model number) that you desire, and you are not even limited to what your own carrier supports (some release new versions faster than others). You will, though, have to dig through the official download portal to seek out OS packages for your model:

From a PC, you can install any compatible (e.g., for your exact BB Model Number) OS package to a BB via this procedure:

Note that while written for "reload" and the Storm, it can be used to upgrade, downgrade, or reload any BB device model -- it all depends on the OS package you download and install to your PC. If that OS package is from a carrier other than the carrier for which your BB was originally manufactured, then delete, on your PC, all copies of VENDOR.XML...there will be at least one, and perhaps 2, and they will be located in or similarly to (it changes based on your Windows version) these folders:

  • C:\Program Files (x86)\Common Files\Research In Motion\AppLoader
  • C:\Users\(your Windows UserName)\AppData\Roaming\Research In Motion\BlackBerry\Loader XML

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Hall of Famer III
Posts: 57,533
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: I can`t update bold 9700 to OS6


johnxspider wrote:

its alive its aliveeee !!! Smiley Very Happy <3  thnx Smiley Happy


Excellent...you are most welcome...enjoy!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Highlighted
New Member
Posts: 1
Registered: ‎04-18-2013
My Device: Bold 9700
My Carrier: Airtel

Re: I can`t update bold 9700 to OS6

all were okay, but its not booting up.. the blackberry and the status bur is showing but after say around 60% its not moving.. help me....

New Member
Posts: 1
Registered: ‎12-27-2013
My Device: blackberry 9700 bold
My Carrier: vodafone

Re: I can`t update bold 9700 to OS6

Many thanks for your detailed description.

I used this and I succesfully upgraded my mobile from OS5 to OS6.

 

Thank you very much!

Norbert
New Contributor
Posts: 2
Registered: ‎10-23-2014
My Device: 9700
My Carrier: Rogers

Re: I can`t update bold 9700 to OS6

And I thought I was  reasonably intelligent. I have just read and re-read all the instructions in this thread and I'm getting nowhere upgrading to OS6.0. I have wiped the 9700 using BBSAK. I have then deleted vendor.xl. And I had  already installed version 6.0 on my PC. Whne I run Loader.exe., that's where it all stops. Everything seems to be greyed out in the Application Loader wizard. Any help would be appreciated.

Hall of Famer III
Posts: 57,533
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: I can`t update bold 9700 to OS6

Hi and Welcome to the Community!


eggman wrote:

And I thought I was  reasonably intelligent. I have just read and re-read all the instructions in this thread and I'm getting nowhere upgrading to OS6.0. I have wiped the 9700 using BBSAK. I have then deleted vendor.xl. And I had  already installed version 6.0 on my PC. Whne I run Loader.exe., that's where it all stops. Everything seems to be greyed out in the Application Loader wizard. Any help would be appreciated.


The normal reasons for that are:

  • You have not deleted ALL vendor.xml files
  • The OS package you downloaded/installed to your PC is not for the exact model number BB that you have
  • The OS package you downloaded/installed to your PC is somehow corrupt
  • There is something else going on with your device preventing the OS load from happening

Also, those instructions are a bit dated now...revised information follows...


1) Make sure you have a current and complete backup of your BB...you can find complete instructions via the link in my auto-sig below.

2) Uninstall, from your PC, any BB OS packages

3) Make sure you have the BB Desktop Software already installed

4) Download and install, to your PC, the BB OS package you desire:

  • http://us.blackberry.com/support/downloads/download_sites.jsp
  • It is sorted first by carrier -- so if all you want are the OS levels your carrier supports, your search will be quick. However, some carriers are much slower than others to release updates. To truly seek out the most up-to-date OS package for your BB, you must dig through and find all carriers that support your specific model BB, and then compare the OS levels that they support.

5) Delete, on your PC, all copies of VENDOR.XML...there will be at least one, and perhaps 2, and they will be located in or similarly to (it changes based on your Windows version) these folders:

  • C:\Program Files (x86)\Common Files\Research In Motion\AppLoader
  • C:\Users\(your Windows UserName)\AppData\Roaming\Research In Motion\BlackBerry\Loader XML

6a) For changing your installed BB OS level (upgrade or downgrade), you can launch the Desktop Software and connect your BB...the software should offer you the OS package you installed to your PC.

6b) Or, for reloading your currently installed BB OS level as well as for changing it, bypass the Desktop Software and use LOADER.EXE directly, by proceeding to step 2 in this process:

If, during the processes of 6a or 6b, your BB presents a "507" error, simply unplug the USB cord from the BB and re-insert it...don't do anything else...this should allow the install to continue.



You may also want to investigate the use of BBSAK (bbsak.org) to perform the wipe it is capable of.



You may also want to try the "Bare Bones OS Reload Procedure" to attempt to narrow down the precise causal item:

  1. Load your OS "bare bones"...if anything is optional, do not install it.
  2. If the behavior presents immediately, then try a different OS with step 1
  3. If the behavior does not immediately present, then run for as long as it takes for you to be sure that the behavior will not present.
  4. Add one thing -- no matter how tempting, just one.
  5. If the behavior does not present immediately, then again run for long enough to be sure it will not have the same problem
  6. Repeat steps 4 and 5 until all things are loaded or the behavior presents

When the behavior presents, you know the culprit...the last thing you loaded.

If the behavior does not re-present, then you know that either step 1 or 2 cured it.

If the behavior presents no matter what, then you likely have a hardware level issue for which no amount of OS or software can cure.



You may also need the use of these tricks:



If you are on MAC, you are limited to only your carriers sanctioned OS packages...but can still use any levels that they currently sanction. See this procedure:

  • KB19915How to perform a clean reload of BlackBerry smartphone application software using BlackBerry Desktop Software

Good luck and let us know!

 



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 2
Registered: ‎10-23-2014
My Device: 9700
My Carrier: Rogers

Re: I can`t update bold 9700 to OS6

Thank you for your response to my post. And you were right. I actually solved the issue and was able to instal OS 6.0 about 20 minutes after I posted. I had missed one of the vendor.xml files, that one tucked away in,

  • C:\Users\(your Windows UserName)\AppData\Roaming\Research In Motion\BlackBerry\Loader XML

Unfortunately I have since run into real grief with the phone. I had disassembled it about a week ago and replaced the trackpad due to it not working. And since I replaced it, it has been spotty, would work, then not work, blah, blah.

And reading in other forums, it sounds like issues with connections on the PCB itself. I think I'm going to grab another 9700 on ebay.

 

Thanks again for your help.

 

 

Wade

New Contributor
Posts: 2
Registered: ‎08-22-2015
My Device: Bold 9700
My Carrier: Glo Mobile

Re: I can`t update bold 9700 to OS6

How can I update my bold 9700 os 6 to os 7 i need some help form anyone thanks
Hall of Famer III
Posts: 57,533
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: I can`t update bold 9700 to OS6


Potent wrote:
How can I update my bold 9700 os 6 to os 7 i need some help form anyone thanks


Hello,

 

If a carrier has released it, then the process documented in post 26 above will accomplish that task. To determine if a carrier has released it, see step 4 of that process...you will have to find out if any carrier has released it, and if so then you can use it. That research effort on your part will not be trivial, as you will see.

 

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................