Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
Contributor
Posts: 11
Registered: ‎10-20-2008
My Device: Not Specified
Accepted Solution

I have AT&T & Curve 8300 running BIS - Can I upgrade…

to version 2.5 of the device firmware along with the companion v4.5 or 4.6 desktop software?

 

Here's a little background:

 

I bought my Curve last fall at an AT&T store.  I had been a quite satisfied Palm customer since 1994 and so had accumulated over 1500 very detailed contact records, as well lots and lots of appointments.  But I had to return my latest Palm device, a Treo 680 within the 30 day warranty period due to a severe problem with battery life.  To my frank amazement, it stay charged up enough for use for more 3-4 hours at a time.  (I'm a heavy data user but not that heavy!)  So I decided to make the big switch, thinking that Palm technology was becoming obsolete anyway and the company's future was in doubt. 

 

It turns out this was a really good move, except for one thing:  with the Treo I had become acustomed to not needing to lug my laptop around on planes, etc. because I could do most anything I needed on the Palm, including most MS Office work via the Dataviz software product Documents To Go.   While this software was not yet available for BB at the time, I was told that this was coming in a few months.  So I decided to get by without MS Office temporarily - really meaning only the loss of MS Word and Excel because I knew that the Curve integrated well with MS Outlook. 

 

But what I didn't expect was to still be waiting 15 months later!

 

As I say, I've been very happy with my Curve and Dataviz did in fact come out with the BB platform support a few months ago.  However, the issue remaining is that this software requires me to upgrade to at least v4.5 BB Desktop (I'm running 4.3 now) and to upgrade to Curve firmware version 2.5 (I'm running firmware v2.4.2 now). 

 

 I was in contact with AT&T "support" again today and I'm still being stonewalled. The trouble is AT&T only supports the software versions I'm running now and apparently have no plans to support anything newer.

 

Obviously there are no worries about running desktop v4.5, but I have two specific questions about the v2.5 firmware:

 

1.  Can I upgrade the firmware to 2.5 and still safely receive AT&T voice and BIS data services?  I guess what I'm really asking is whether there are compatiability issues I shold be aware of???

 

2. If I find later that have any issues, or AT&T arrests me (kidding, sort of) can I safely downgrade back to firmware v2.2.4?

 

I don't care a wit about whether AT&T offically supports these O/S versions.  There little of that expected or needed anyway.  What I'm asking is "will it work technically or is AT&T doing something funky on their network with file transfer protocols, etc.?"

 

Any feedback here will be much appreciated!

 

Rodger Beard

Smiley Wink

 

Guru I
Posts: 19,020
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

1) yes you can upgrade. Just remove the vendor.xml file.
nobody knows what ATT is doing before releasing its OS 4.5.

2) installing an OS is always reversible. You can install 4.5 today, and tomorrow install 4.2.2. Just remember to do regular backups.



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
Contributor
Posts: 11
Registered: ‎10-20-2008
My Device: Not Specified

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

Thx!

 

But I realize I can install the desktop software and then de-install it - afterall it's just another PC app.  Frankly I tried it several months ago but then discovered that I also needed to install the firmware and until I did this I could not sync the desktop to the device.  I also had problems with my Roxio 10 application which was already installed so I backed it out. 

 

What I'm worried about s version 2.5 of the firmware.  SAhould I take a chance???

 

Rodger

Posts: 95,504
Likes: 24,546
Solutions: 6,397
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

OS 4.5 is what you call the "firmware" on the device.

 

BIS 2.5 is the version of BlackBerry Internet Service AT&T is running--you have nothing to do with that. 

 

So:

1. That was upgraded in July by AT&T and RIM. Done.

2. No. You can't downgrade the RIM servers and your carrier servers.

 

What you need is your handheld device upgraded to OS 4.5 to get DocumentsToGo. 

 

The one thing you didn't say in all that was your actual model number, 8300 or 8310 (or possibly 8320)? That is what you need to need to know to upgrade your device as the OS releases are ALL very model-specific.

 

I am on ATT and have been running various version of 4.5 for months, you will be fine. Do a complete backup of your BB first using Desktop Manager on your PC (you that that installed, right?). If so , look at the Help, About and what is the version of your DM?



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Posts: 95,504
Likes: 24,546
Solutions: 6,397
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

1) Use the link below to your model. 

2) Do a complete backup with Desktop Manager. I always do that, AND sync my data/contacts, calendar, to Outlook as well, to be safe.

3) Follow the instructions in the link EXACTLY as posted, and IN ORDER as posted, and you will be fine.

 

If you have an 8300:

http://www.blackberryforums.com/general-8300-series-discussion-curve/151848-latest-os-8300-v4-5-0-10...

 

for the 8310:

http://www.blackberryforums.com/general-8300-series-discussion-curve/153055-latest-os-8310-4-5-0-108...



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 11
Registered: ‎10-20-2008
My Device: Not Specified

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

I followed the instructions provided very carefully and now have V4.5 of Desktop application installed on my PC and apparently running properly.  The device and the PC have since synced successfully.

 

However, I did not get a prompt to upgrade as the instructions indicated would happen when I plugged in the device via USB (I have Bluetooth sync turned off).

 

Is that I can manually force the device to upgrade? 

Posts: 95,504
Likes: 24,546
Solutions: 6,397
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

Ok, on your BB, look at Options > About. What does the third line down say... starting with "v.4.xxxxx". What is that number?


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 11
Registered: ‎10-20-2008
My Device: Not Specified

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

Thx for the quick reply.

 

This line says v4.2.2.166 (Platform 2.4.0.73)

Posts: 95,504
Likes: 24,546
Solutions: 6,397
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

Then you are correct, you have not upgraded the OS on the BlackBerry.

So, follow the instructions in the link,download and install the OS to your PC, delete the vendor.xml file, etc.



1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
Contributor
Posts: 11
Registered: ‎10-20-2008
My Device: Not Specified

Re: I have AT&T & Curve 8300 running BIS - Can I upgrade…

I've been away from my desk for a day (eye surgery) so am a little slow replying.  I wish I had better results though as this is becoming a real drag.

 

Latest is that I've tried to follow the instructions exactly, indeed several times.  No cigar.

 

However I have discovered another perhaps useful symptom:  when I try to run the full backup before the process I get an error dialogue which says "Error backing up database(s)".  The only reply to this error message is "OK".  I've checked the subdirectory where the .IPD backup file should be and it is not there...  So the backup process is failing obviously.  I'm guessing I know the cause. 

 

I leave my BB plugged in to the USB cord on my PC overnight most nights and then automatic backups run in the early AM, typically when my wife is using the computer.  She tells me that she has seen this error before (frequently, for a couple weeks at least).  I'm thinking that this symptom is most probably related to the fact that she recently bought her own BB (hers is a Curve 8310) and plugged it in and did try to sync up with something on the PC desktop.  She uses Windows Live Mail as her email client and I use MS Outlook so it didn't work but I believe she is now "registered" with the BB Desktop.  from a timing standpoint this ties with the start of the backup error message so I'm thinking my BB profile does not agree with that the backup software now has.

 

We've discussed and my wife says she has no need to connect (not enough names in her phone book to worry about - makes me wonder why she wanted a BB in the first place) so I could purge her device from my PC if is this is warranted.

 

Does this sounds like a promising root cause?  If so, what recovery is most appropriate?