Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
New Member
Posts: 1
Registered: ‎04-22-2013
My Device: Touch
My Carrier: 410997778

Issue with page load and "Fetch Request Failed because it requires authorization" message

We use BlackBerry Bold to test webpage  we did (link below), after a few minutes of loading I was given the message "Fetch Request Failed because it requires authorization" the first time I tried to load the wind-farm page. I retried it a few minutes later and it worked fine, no issues. 

 

Some other BBs don't load wind-farm page (page with pop-ups) at all. That page uses JQuery to do popus when you click parts of the image. Look like we have issue only with BBs Smiley Sad

 

Here is link to a page we are testing: http://demobox.bcs-hq.com/test/wind-farm.html

 

Any help greatly appreciated!

THanks!

Guru I
Posts: 19,020
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: Issue with page load and "Fetch Request Failed because it requires authorization" message

here is the cheat mode :

the wind farm links to this video :
http://demobox.bcs-hq.com/test/videos/wind-farm.mp4

the wind turbine indeed links to a JS-evolved website.

if you have a Bold 9700 or prior, you may have a better website rendering using the browser named OPERA MINI.
What is the model of your BlackBerry Bold ?



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Contributor
Posts: 3
Registered: ‎12-16-2013
My Device: Blackberry Bold
My Carrier: Not Sure

Re: Issue with page load and "Fetch Request Failed because it requires authorization" message

Hello,

I am having this same issue - where a Blackberry Bold user encounters a "Fetch Request Failed because it requires authorization" message. What is confusing me is that there is no authorization required to view this page (i.e. there is no need to log in or provide a username/password). What would be the cause of this error, and how what steps would I need to take to debug the real issue? The URL of the page I am having difficulty with is 'demobox.govtools.us/FERC'. Because this is not an application I'm building for personal use, but rather for a client, I don't want to require them to use a specific browser or download a specific application, because that will discourage users from using the application.

 

I would appreciate any feedback/advice you might have :-)

 

Thanks!!

New Contributor
Posts: 3
Registered: ‎12-16-2013
My Device: Blackberry Bold
My Carrier: Not Sure

Re: Issue with page load and "Fetch Request Failed because it requires authorization" message

Also, the version of Blackberry is the Blackberry Bold 9930