Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 1
Registered: ‎08-26-2010
My Device: Blackberry Curve 8520
My Carrier: Orange

Letter 'A' not working

Today the letter A on my blackberry 8520 stopped working completely. when pressing either the letter Q or S it will come up as Qa or Sa  . . It had happened once before but it appeared to fix itself after not being used for a few hours. I have read something about moisture on other forums and I feel this may be the answer but it only affects the letter A. Does anyone have any suggestions as to what I should do?


Thanks Smiley Happy

Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Letter 'A' not working

Hello deano8904 and welcome to the BlackBerry Support Community Forums.


You can try reloading your BlackBerry software.


Be sure back up your device first as all data will be wiped out.


To do the reload consult KB11320


Before restoring any data, test the A key. If its still acting up, you might want to contact your wireless service provider.


To restore your data consult KB10339 (Desktop version 4.3-5.0) KB23680 (Desktop version 6.0)



Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Forums Veteran I
Posts: 2,119
Registered: ‎08-07-2010
My Device: Bold 9900, Playbook , HS-700 headset
My Carrier: Rogers

Re: Letter 'A' not working


 have you tried a battery pull?

1). Please thank those who help you by clicking the Like Button beside the 'Reply' button.
2). If your issue has been solved, please resolve it by marking "Accept as Solution" on the correct post!
3). Remember to have fun! We are all in this together!
4). Follow me on Follow Raelic1337 on Twitter

New Member
Posts: 1
Registered: ‎09-11-2011
My Device: Curve 8520
My Carrier: Orange

Re: Letter 'A' not working

Did you have any luck with this problem? I have the same problem, for a brief moment it worked with the keys ‘s q, w, s and z’ but now the 'A' button isn't working at all. I have tried the battery pull, restoring the phone to factory settings (removing all media) and updating the software, but to no avail. At the same time the buttons either side of the trackball (answer, menu, back and hang-up) also intermittently fail taking ages to respond while the trackball remains functional. Any ideas?



New Member
Posts: 1
Registered: ‎03-13-2012
My Device: Torch 9800
My Carrier: ICE

Re: Letter 'A' not working

I had the same problem, I bought the Membrane and replaced it myself and it voila, issue fix!