Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎12-01-2011
My Device: Blackberry Bold 9900
My Carrier: 61412008578

Re: Browser is not working anymore BB Bold 9000

fantastic advice - I too had the same problem - bold 9900 with BES - the factory reset did the trick


many thanks

New Member
Posts: 1
Registered: ‎02-03-2013
My Device: storm 9530
My Carrier: 2 second handed

Re: Lost browser " not currently have any Browser Configuration Service Book Entries"

When I do that it says registration message queued it will be sent once data coverage is available.

obrienaj wrote:

Thanks to this old post that I found, the problems has been fixed...




Please try the following:


1. From the home screen press Options > Advanced Options > Host Routing Table.


2. Once the Host Routing Table is open, press the menu key(2nd button in from the left on the bottom) and press "Register Now".


You should see registration message sent and will get a registration email. If your browser does not restore, please remove the battery for about 10 seconds and put it back to do a reset. If you still do not see the browser I would contact your wireless provider to have your service books pushed out.


You can also look for the Email Settings icon in the Setup folder. Click on this icon and you may find the option the send service books.


Hope this is helpful.



Posts: 1
Registered: ‎07-25-2014
My Device: blackberry tour 9630
My Carrier: verizon

Re: Lost browser " not currently have any Browser Configuration Service Book Entries"

hi i am new to blackberry world. I am using blackberry tour 9630 verizon. I brought it from kuwait and unlocked it. Right now iam using TATADOCOMO gsm service ,while trying to browse the internet it says "not currently have any Browser Configuration Service Book Entries , contact your service provider".What should i do?

I have activated Blackberry BIS plan also.But still unable to browse.

I tried by sending service books by HRT option several times but nothing happened.And already tried the battery pull up option also.

I tried to contact service provider , they are suggesting me to change gsm sim to cdma then it will work.

Is it necessary to change gsm to cdma ?

Can anyone please suggest me ?