Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 10
Registered: ‎03-20-2009
My Device: Not Specified

Mass Storage device feature won't work

I've spent more than 6 hours on the phone with BB tech with two different Bolds trying to get this feature to work.  We reset, re-installed, check settings, rebooted, etc multiply times.

After the first three hours, the BB tech concluded that the phone was defective and advised ATT to send a replacement.  After I got the replacement Bold I spent 3 hours on the phone with a "senior" tech trying to solve the same problem, after which he said he was going to consult with some other senior techs and get back to me the next day.  I never heard from him.

I've tried 3 different SD cards from 2 differnet manufacturers, and 5 different win xp computers.

It is frustrating because I can connect with Desktop Manager and transfer files back and forth with media manager.  I can use the Bold as atethering modem through DUN but it cannot be discovered by ATT Communications Manager.

I wonder if the two problems, the lack of mass storage capability and failure to connect with ATT communications Manager, are related to some obscure setting on the Bold, perhaps a security setting of some sort.
Posts: 10
Registered: ‎03-20-2009
My Device: Not Specified

Re: Mass Storage device feature won't work

[ Edited ]

I just found the solution from another post on this forum.  The fix is to download a program and run it on your pc while BB is connected to ypour PC.  There is a link to the fix in a thread at pinstack (apparently there is some prohibition on posting links on this forum so I won't post it.  But I searched for "Some people are have issues with Mass storage" on pinstack and found the fix.

 Apparently, the mass storage feature is disabled if someone tried to (or actually did) unlock the phone.  As both the first and second phone I got from ATT were refurbished phones, I now suspect that either the phones were returned to ATT after someone tried to unlock them and the ATT refurbish software doesn't fix the problem, or the ATT refurbish software actually causes the problem.
I'm asking ATT to send me a 3rd phone for which they have certified that all features are working, including the mass storage device feature.

 BTW, this fix also fixed the inability of ATT Communications Manager to find the phone as a modem.

 So I'm very grateful to the peson who posted the reference to the fix on this forum, and the person who posted the link to the fix program on pinstack.

 However, I'm very disappointed in both ATT and BlackBerry tech support.  I spent more than 10 hours total with ATT and BB tech support trying to resolve this problem. All those tech support people acted as if I was the first person who had ever called in with this problem.

 BB tech concluded that the first phone was defective (which, I guess was technically true, but could have been resolved by running a simply reset program.)


ATT Data support tech concluded that ATT Communications Manager had a bug and he said he was "going to write up a bug report and send to the developers"  (I didn't believe it, but who knows, maybe he really meant it.)

In any event, ATT should not be sending out refurbished phones (each of which comes with a "Recertified by ATT" sticker) when in fact not all of the phone's features work. 

Message Edited by wnyhiker on 03-23-2009 12:20 PM