Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Visitor
Posts: 1
Registered: ‎05-09-2011
My Device: BlackBerry Curve 8900
My Carrier: o2

My 8900 wont let me download app world updates

Hi

 

My 8900 wont let me get a blackberry app world update and so I can't use it, each time it goes into browser I click next after it asks for preferred language and it comes up with "Sorry, the requested item could not be loaded!"

 

Please tell me what I can do to fix it as I cannot use BBM until it is fixed as I need to redownload that as that also  stopped working!

 

Please help!

Highlighted
Forums Veteran I
Posts: 1,898
Registered: ‎02-23-2011
My Device: Curve 8520 OS v5.0.0.681
My Carrier: Orange UK

Re: My 8900 wont let me download app world updates

Hi

 

The Blackberry is designed to be reset by removing the battery whilst the device is powered-on. Leave the battery out for a minute or 2.

See if that resolves the problem. If not, you haven't given much to go on, so please provide as much as you are able of the the following

Blackberry Model.
Carrier Name.
Do you have a Data Plan?
Operating System Version go to Menu > Options > About - it looks like v5.0.0.681
Memory for Device and SD Card Options > Memory
Any error statement or code.
The Exact nature of problem - the more info the better.
When this started and whether it started just after an update or new App download and which App/s theme/s download.

Blackberry Best Advice - Back-up weekly

If I have helped you please check the "Kudos" star on the right >>>>
Visitor
Posts: 1
Registered: ‎07-12-2013
My Device: curve 8900
My Carrier: cytavoda

Re: My 8900 wont let me download app world updates

hi

 

i tried to download the latest version of blackberry app world on my phone

i downloaded it from the website and it was the same version my blackberry is an 8900

im on cytavoda in cyprus and my version of blackberry is a 4..6 so help