Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
Visitor
Posts: 1
Registered: ‎12-19-2011
My Device: Blackberry Curve 8900
My Carrier: O2 - UK

Need help using WiFi on my BB 8900 while abroad! Please help

Hello everyone, 

 

I am an O2 UK costumer spending the holidays in France. Since I arrived 3 days ago, I've been using my house's WiFi network to access facebook, BBM, e-mails etc and it worked just fine.

Last night, I briefly put another SIM card (Orange - France) in my unlocked blackberry, and immediately realised that Internet wasn't working anymore. I thought it came from the new SIM so I put the O2 one back in, (the one that was working just fine). But it didn't come back.

 

I saw several messages similar to this one, but so far no solution has solved the problem.

 

I tried changing the browser configuration to Hotspot Browser, deleted my saved WiFi connection and put in back in, re-booted the device several times, turning all connections off then back on, but nothing does it. 

 

My phone seems to be connected to my network just fine, although the Wifi sign stays grey and not white (like it used to be when it was working).

 

The weirdest thing is: Although I can't use BBM, receive e-mails or browse the Internet, I can still access Facebook (but I don't receive notifications). 

 

If anyone has an idea on how to fix it, I would be extremely grateful. Thanks a billion and happy holidays!