Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Contributor
Posts: 20
Registered: ‎12-28-2008
My Device: Blackberry Storm
Accepted Solution

No Valid SIM Card

I've got a storm 9530 on VZW, latest official OS. A bit ago I got a SIM card error at random, and now I'm seeing "No Valid SIM Card" in the advanced options. I've tried removing/replacing it, with no change. I know that in the US the card isn't actually "used", but I'd still like to know why its busted.

 

Any ideas?

Hall of Famer III
Posts: 57,244
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAF518), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: No Valid SIM Card

Hi!

 

There are a lot of reasons it could be wiped -- mostly about EM. What I'd suggest is taking your Storm in for warranty evaluation. It could be that the Storm itself had some kind of surge that wiped the SIM...which would, if true, mean that even if you got the SIM replaced, it could happen again. Which would mean that you need an entire new device rather than just a new SIM. Better to be safe.



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Super Contributor
Posts: 302
Registered: ‎03-17-2009
My Device: VZW Storm 9530 OS. 4.7.0.148

Re: No Valid SIM Card

I read on one of the post on here about the click screen not responding in some areas.  The "do it yourself fix'' was to loosen the "two" #5 torque screws located in back,under door ( one having a red sticker with a white strip on it) a 1/4 turn or so. I tried this and in the process it loosened the little metal plate that holds the SIM CARD in place too. So I all of a sudden got the SIM CARD error also. I retightened the torque screw next to the SIM CARD a 1/8  turn and it was reading the SIM CARD again.... If your feeling brave you can try to tighten the screw JUST a little.... 1/8 of a turn maybe and see if it locked it down some.

If not feeling brave take it to phone tech and ask them too try this... If it works, It's better then replacing phone and going thru the reinstall of all your contacts apps. and just plain ol' hassle of waiting on a new phone. I used a small eye glass flat head screwdriver that fit just right if you don't have the right size torture driver....

 

P.S  loosening the screws did fix my clicking issue.... I just may have loosened them too much and I only went a 1/4 turn.... Backing the one down by the Sim down by a 1/8 ...all fixed.....works great now

--------------------------------------------------------------------------------
Please remember to resolve your thread.
Put the check mark in the green box that contained your answer!
Please click Kudo's for those who provided help. Thanks
--------------------------------------------------------------------------------
Contributor
Posts: 20
Registered: ‎12-28-2008
My Device: Blackberry Storm

Re: No Valid SIM Card

Tightening the screw seems to have fixed it nicely, thanks for the tip.