Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Hall of Famer III
Posts: 58,181
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Not receiving some emails

Hi and Welcome to the Community!


ColumbusNYC wrote:

 

The only unifying factor is that they are not reaching my Blackberry but are reaching my Outlook on my desktop.

 



You did not say, but how exactly is this email account integrated? BIS or BES? If BES, then you need to work with your BES admins. But, I suspect that it is BIS since the carrier/RIM would not really have been able to help with BES. Hence, I have only one suspicion left...

 

  • Is there any other client that is retrieving these emails? If there is and that client is removing emails from the server when it does, then that could be the cause
  • What is Outlook doing when it retrieves emails? Does it remove them from the server when it does so? If so, then that could be the cause.

It is tricky to configure a separate email client (e.g., Outlook) so that email flows properly to the BB. By design (for those email services that are not true PUSH), BIS checks your email service every 15 minutes for new things...and lowers that interval after it finds something new, slowly increasing it again (as long as there is nothing further "new) until 15 minutes is again the interval. During those minutes between BIS connections, if an email arrives AND another client retrieves/removes it from your email server, then there would be nothing on the server when BIS next makes it's "new stuff" check of the server. So, it is important to be cognizant of this timing when configuring a different email client (e.g., Outlook)...if it retrieves, for instance, every 5 minutes AND it deletes (from the server) when it does so, then there would be very little "new" items for BIS to retrieve/Push when it does it's scheduled check.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Member
Posts: 3
Registered: ‎04-19-2012
My Device: Bold 9900
My Carrier: AT&T

Re: Not receiving some emails

Thanks for your quick reply.

This is a BIS account. It is an att.net email account (which is viewed as a Yahoo account) so that it pushes automatically to my BB. The email server is set to never delete messages from the server. All of the email is supposed to go to all of my devices (BB, iPad, etc...) I get 100 emails/day and am now finding that a handful do not make it to my BB, which is a real issue since I don't have time to scour Outlook each day for missing emails.
Hall of Famer III
Posts: 58,181
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Not receiving some emails


ColumbusNYC wrote:
It is an att.net email account (which is viewed as a Yahoo account) so that it pushes automatically to my BB.

To clarify, I don't think that Yahoo/ATT is true PUSH. Rather, the BIS service is handling the appearance of PUSH from the perspective of the BB. But the time factors I mentioned above still apply (at least I think they do...I haven't bothered with a Yahoo email account on a BB in quite some time.)


ColumbusNYC wrote:
The email server is set to never delete messages from the server. 

That was not my question...my question had to do with the email CLIENTs (e.g., Outlook, other devices, etc.). If any other client is deleting from the server when it retrieves, then the timing factors I mentioned would apply.

 

But given what you say, it's sounding like no email client is deleting anything from the server...but you do need to validate that to be 100% certain. You also should validate, at the Yahoo/ATT server (not via any client) that those missing emails are actually on the server. If any client is deleting them from the server via any means whatsoever, then that can explain why they do not appear on the BB.

 

You might also check this setting (just a guess):

  • KB11056 Filtering spam email messages from a Yahoo! Mail account

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Member
Posts: 3
Registered: ‎04-19-2012
My Device: Bold 9900
My Carrier: AT&T

Re: Not receiving some emails

None of the email clients are deleting from the server. When I go to the ATT website, all of the missing emails are sitting in the Inbox on the server. That's why this is such a mystery.

We re-sent the service books last night too - to no avail.

Also - it isn't a case that some email addresses are being blocked. I have been receiving emails all morning on my BB from one person - and now the latest email showed up only on my Outlook and not on my BB.
Highlighted
Hall of Famer III
Posts: 58,181
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Not receiving some emails

Have you yet removed and re-configured that email account on your BB? Indeed, if you have multiple email accounts, you may want to remove them all, wait about an hour, and then put them back. Sometimes, when BIS itself is upgraded (as it is from time to time), the upgraded version does not become available to an end user until all accounts are removed and then re-configured.

 

You also might have more luck searching the public KB's for useful articles perhaps.

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................