Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Highlighted
New Member
Posts: 2
Registered: ‎09-15-2009
My Device: Not Specified

Phantom Headphones

My 9630 believes it has headphones plugged into it even when it doesn't.  Therefore, I am unable to use the phone without headphones.  Without headphones, the handset and/or speaker emit no sound.  I've tried the following (note that my efforts became increasingly drastic when previous efforts failed):

 

1) Depress the blackberry button looking in the menu for "Activate Speaker"  or  "Activate Handset."  It did not appear.

 

2) Plugged both the headphones that came with my blackberry as well as other headphones in and out of my device various times both quickly and slowly.  With jiggles and without jiggles.

 

3) Read every post on this forum I could find on the issue and tried all solutions proposed.

 

4) Played MP3's and found that I was fully able to use the speaker and the handset without headphones as long as I wasn't using the phone functionality.  MP3's were fine. In the blackberry menu, the "Activate Handset" and "Activate Speaker" options would appear as they should.  When I would then try to make a phone call, the phantom headphone would reappear (icon and all on the upper left corner). 

 

5) I did the battery pull several times with headphones plugged in and without headphones not plugged in.

 

6) I backed up my blackberry and then did a complete wipe (i.e. I went to Options: Security Options: General Settings and selected "Wipe Handheld" and typed in "blackberry"

 

I can't believe it is a hardware problem given the speaker and handset work fine with MP3's.  However, if it is a software problem, I am confused as to why doing a complete WIPE didn't fix it.  My wife has exactly the same device purchased at the same time and hers does not have this problem. 

 

Any thoughts? 

 

Visitor
Posts: 1
Registered: ‎09-17-2009
My Device: Not Specified

Re: Phantom Headphones

i have this exact same problem and have exhausted every avenue i can think of trying to fix this issue. can anyone help please?
Visitor
Posts: 1
Registered: ‎12-26-2009
My Device: Blacberry 9630 Tour
My Carrier: Verizon

Re: Phantom Headphones

Did you ever resolve this problem?  I have this problem also and don't know how to correct it. 

New Member
Posts: 2
Registered: ‎09-15-2009
My Device: Not Specified

Re: Phantom Headphones

Never resolved it.  I was still within 30 days of purchase, so I returned my device and received a new device which worked fine.