Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Developer
Posts: 8
Registered: ‎09-02-2008
My Device: Torch
My Carrier: Vodafone UK

Re: Bluetooth connections

[ Edited ]



From what I can gather per the above posts, I believe my issue in attempting to connect my Blackberry Pearl 8100 is similar to the above. My device has paired successfully with my PC using XP's BT wizard as suggested in KB04132,  however when I try to configure BT to add the Device using the BB DesktopManager software, I get a message  "Verify that the Bluetooth enabled device is configured with the BlackBerry Desktop software" My device is not displayed in this window.  I then found the following script in the KB04132 solution Additional Info 

Additional Info  If your BlackBerry smartphone cannot be found on the Add Bluetooth Device window, your BlackBerry Enterprise Server may not have the proper IT policies enabled. Contact your system administrator to verify that the following IT policies are set to FALSE:
  • Disable Desktop Connectivity
  • Disable Wireless Bypass
Note: These IT policies are only available in BlackBerry Enterprise Server software version 4.0 Service Pack 3 and later.

Note: If the BlackBerry smartphone has an IT Policy that has removed the desktop connectivity service (located in Bluetooth Options), the BlackBerry smartphone will be able to pair, but will not be located by the BlackBerry Desktop Manager. http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB04132&sliceId=SAL_Pub... 

 I have checked my organisations IT policy with our administrator, where he has informed me that our IT Policiesare set as follows:

Bluettooth Policy Group ->

Disable Bluetooth

Disable Pairing

Disable Handsfree Profile

Disable Serial Port Profile

Disable Discoverable Mode

Allow Outgoing Calls "In the absence of this rule a default value of FALSE will be used.


Am I correct to assume that the above settings on our BES server is the reason why I cannot connect my device via Bluetooth to my PC, or should I be looking at other troubleshooting aspects.


Hope you can help, and thank you in advance for your input.



Message Edited by PeteBloem on 09-06-2008 09:21 PM