Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 2
Registered: ‎02-26-2011
My Device: RIM Blackberry Torch 9800
My Carrier: O2

Ringtone issue

[ Edited ]

Hi there.


I'm running device software v6.0.0.246 which is the accredited OS for my carrier O2-UK.


The default ringtones have been somehow removed.


I've tried tried soft-resets, battery pulls, reloading software on the device, installing/uninstalling DM and OS on PC, changing profiles and all but i've had no luck!


Has anyone else had this issue and do they know of any fixes so I can get the default tones where they should be.


All I hear now are three beeps (like midi piano) when someone tries to get in touch or when the phone is plugged in or restarted (I have events sounds on).


Here's a screen show of what I can see if I try and select a ringtone.



Any pointers in the right direction would be greatly appreciated.


I don't think it is a problem with the device but perhaps with the software. I find it unlikely however as I have searched for this problem on the web and have not come across it before.


I have suspicions that it could be related to third-party applications.

But I am not sure of which one it could be.


I've tried uninstalling them but the problem is still there!



Any ideas?




Forums Advisor I
Posts: 676
Registered: ‎01-01-2011
My Device: Torch-Q10-Passport
My Carrier: Vodafone

Re: Ringtone issue

hi and welcome to the forum.

just a guess but i think you could be looking in downloaded ringtones.

try going to setup in all menu > ring tones > ringtone drop down menu and see if they are all there.


let us know if that works.

New Contributor
Posts: 2
Registered: ‎02-26-2011
My Device: RIM Blackberry Torch 9800
My Carrier: O2

Re: Ringtone issue

Hi there, thanks for your reply.


Yes I've explored all possibilities and have tried what you suggested.


The problem is intermittent and sometimes a battery pull can resolve the issue whereas others they do not appear at all as shown in the image in my last post.


I decided to install OS6.0.0.448 earlier today from (3UK) to see if there would be any improvements.

I wiped the device using BBSAK and reinstalled fresh via apploader.


To test whether it was an issue with a third-party application or not decided not to install anything extra other than what came pre-loaded in the install.


It's been fine all day however now the ringtones are not working anymore.


They are available to see at the moment as I have not restarted my device or done a battery pull - (it's worth mentioning that this always happened before I upgraded to 448 and the would normally disappear after the restart).


Interestingly enough however I did receive this error message earlier today which seems to be related to my issue...


Uncaught exception: Application net_rim_bb_profiles_app (313) is not responding; process terminated.



I suspect that this file is corrupted... however I have no idea how I could fix this as a device wipe / OS installation has not worked for me.


Any help would be appreciated.