Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Member
Posts: 1
Registered: ‎10-10-2012
My Device: Storm
My Carrier: Verizon

Screen wont work on my Blackberry Storm 1

Bought a blackberry storm online. got it in and the touch screen wont register my touch. How can I fix this?

Retired
Posts: 2,649
Registered: ‎04-01-2008
My Device: 9500, 8110, 8700, 8220, 9100, 9800, 9810, Z10

Re: Screen wont work on my Blackberry Storm 1

Hello 1sForgotten

 

Welcome to the forums. 

 

In this case we can try to reload the software on the BlackBerry® smartphone to make sure it is running the latest version and there are no issues with the OS.

Here is how to backup your BlackBerry smartphone http://bbry.lv/oPVWXc

Once you have backed up your BlackBerry smartphone please follow the link below to complete a clean reload of the BlackBerry smartphone software.

Link: http://www.blackberry.com/btsc/KB03621

Once completed test it and proceed with a selective restore, here is how to restore http://bbry.lv/qgQxLo

Thank you

-SR

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

New Member
Posts: 1
Registered: ‎10-13-2011
My Device: Blackberry Storm 2 9550
My Carrier: Verizon

Re: Screen wont work on my Blackberry Storm 1

I've had a Storm2 9550 since Jan. 2011. Has worked well, on balance. However, the screen has gradually been less functional. This afternoon, it ceased to respond at all. Regardless of where I touch the screen, it will not execute a command. What do I do? Help!
Highlighted
New Contributor
Posts: 5
Registered: ‎03-04-2014
My Device: Storm 2 - 9520
My Carrier: vodafone

Screen wont work on my Blackberry Storm 2

i have a problem on my storm 2, the screen wont open anything when i touch, it can only highlight. i can even scroll up and down but i cant opne anything. tried to reset it, even updated my OS but still not working. helpppp