Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Contributor
Posts: 15
Registered: ‎11-16-2012
My Device: None
My Carrier: Mobitel

Setuping BlackBerry Dev Alpha for development

Hello,

 

at first I did not know where to put this, since developer support forums are more code oriented, so I choose this forum, I hope it is okay, otherwise please move it to correct forum.

 

I am trying to setup BlackBerry Dev Alpha device for development on my workstation. I am running Windows 8 Pro x64, freshly installed and I installed latest BlackBerry Development Kit and BlackBerry Device Manager. The Alpha device was updated to the latest version. Now I am having trouble connecting to the device in the IDE.

 

My question is, why my PC cannot connect ot BlackBerry Dev Alpha device? IDE displays Unable to connect. Check USB cable or WiFi connection.

 

The following facts are true:

 

- Device is connected with normal MicroUSB cable without hubs

- Device is detected in BlackBerry Device Manager and IP is displayed

- Development mode is on, password is set

- IP of  the device is 169.254.1.1, set in development mode screen (tried also another IP, no effect)

- Target in Momentics is created manually (autodiscover does not work)

- Windows Firewall is OFF

- Pinging the device IP in command prompt returns no reply

 

Is there something wrong with the device? Considering I cannot run camera, I might have received bad device.

 

Best Regards,

 

Legoless

Highlighted
Contributor
Posts: 11
Registered: ‎12-17-2012
My Device: BlackBerry Dev Alpha B
My Carrier: AIS

Re: Setuping BlackBerry Dev Alpha for development

[ Edited ]

I got same sometime.

 

I'm use action as below to solve.

1. Check USB Cable

2. Check Device in Device Manager , you may found UNKNOW Device or device with   yellow "!" sign.

3.  Remove all unknow device.

4,  unplug USB Cable and re-plug again

5.  try detect hardware by scan hardware,

6, If device not complete ,  Try force install device driver for new hardware that you computer found.

 

Hope it help.  

 

Sorry for my English.   

If it helped please click LIKE  for me.

 

Thank.

 

Tamamaxx

 

 

 

 

 

 

Contributor
Posts: 15
Registered: ‎11-16-2012
My Device: None
My Carrier: Mobitel

Re: Setuping BlackBerry Dev Alpha for development

Thank you for your answer.

1. USB cable is fine, I have many of them, none of them works.
2. BlackBerry Device Manager successfully detects the device and even displays time connected. The device has yellow sign in computer's device manager.
3.,4. Removed the device, unplugged cable and plugged it again, no difference.
5. Tried that, Windows says that I have the latest driver.
6. Device still not recognized, apparently it is the driver issue. Which driver should I install?

Thank you,

Legoless