Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 2
Registered: ‎03-06-2013
My Device: Blackberry Torch 9800
My Carrier: Vodacom

Sim Error

I have the BlackBerry Torch handset and I have a problem whereby the phone loses signal from my network provider. It says SIM ERROR and a SOS signal appears.

 

Is someone able to assist with my problem please?

Elite II
Posts: 7,974
Registered: ‎06-01-2012
My Device: Curve
My Carrier: BSNL

Re: Sim Error

Hi Waiter01

 

Welcome to BlackBerry Support Forums

 

 

Are you sure you're in an arrear where you have a good network coverage , Or have you tried to call your carrier to know if they were having any issues with there Network ! 

 

Regarding your present symptom you can refer to this Knowledge Base :

 

 KB03448 : Network status indicator shows " SOS " on the BlackBerry smartphone

 

Go through those suggestion and see if it helps.

___________________________________________________________________________

Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.
Highlighted
New Contributor
Posts: 2
Registered: ‎03-06-2013
My Device: Blackberry Torch 9800
My Carrier: Vodacom

Re: Sim Error

Network Coverage is excellent when this happens.

I forgot to mention on my previous post that I have to restart the handset in order for it to work again.

 

The Sim Error is happening far to often and it is really annoying. I even tried changing my sim card.

I've googled the issue as well and it seems that other BlackBerry users with other model handsets have the same issue. 

 

How can this issue be rectified?

 

Elite II
Posts: 7,974
Registered: ‎06-01-2012
My Device: Curve
My Carrier: BSNL

Re: Sim Error

Hi Waiter01

 

 

Thanks for those info !

 

If your device detects the network after a battery pull , then please Go through the KB and you can try # Step 10 , try Updating / Reloading your Device Software to rule out any software issue ,which might fix your issue.

 

 

Try it and let us know of your progress.

___________________________________________________________________________

Click " Like " if you want to Thank someone.
If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.