Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
Developer
Posts: 117
Registered: ‎02-12-2009
My Device: Not Specified
Accepted Solution

Storm Versions and Java Support

Hi All,

 

As per information on website about Blackberry storm, they have only one version 9530. While searching on forums i could see some people talking about 9500 also, see info here. Is it that now we have only one version now? Please correct my understanding.

 

As per information i have Blackberry storm is released with Vodafone and Verizon. Vodafone is GSM based and Verizon is CDMA based. So i assume that Storm supports both GSM and CDMA.

 

It may be a silly doubt but still i will ask. As CDMA based devices are Brew based generally, i had a doubt that in case we have two versions of Storm, do both support Java. So that applications we develop using JDE4.7 will work on both versions.

 

Please correct my understanding and provide some information.

 

Best regards,

Sandeep

Highlighted
Guru I
Posts: 19,017
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: Storm Versions and Java Support

hello,

the Storm has two devices : 9500 and 9530.
9530 = 9500 + CDMA

I today use a 9530 in France, where there is no CDMA. It is then exactly as if I had a 9500.



Modern BlackBerry devices (with trackball or touchscreen) have an OS that is made of Java (and not Brew), so applications can be developped in Java for the BlackBerry. You can find valuable information by clicking in the 'DEVELOPERS' link on top of this page.

Java applets are not supported by the browser.

be careful which JDK you use for your development.



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
Moderator
Posts: 2,386
Registered: ‎03-31-2008
My Device: Not Specified

Re: Storm Versions and Java Support