Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Contributor
Posts: 3
Registered: ‎04-21-2013
My Device: Torch 9860
My Carrier: MTN

Torch went blank and nuked itself.

I bought this brand new 9860 from an auction. Worked OK for 5 days and whilst charging it (at 75%) it just went dead with the red light flashing 30 secs off and 30 secs on.

Recharged battery via a universal charger to 4.2v and did the Application Loader thing with bat pulled and clicked NEXT at "Pin Unknown".

Step 1 went well and I reinserted the bat at the "Initializing" . Then in step 2 it said "Reconnect to JVM" thing and then the dreaded "App Loader cannot connect to device" popup came up.

Tried new fully charged bat and the same happened.

Changed to my laptop and the same happened.


I have now posted a thread where all problems on this end. I have spent the whole week reading everything on the internet on this problem and it is a very, very common problem since 2009 and they all end Here. No fix from RIM. No answers. Been through all the KB stuff on it and still no fix.



Hall of Famer III
Posts: 59,102
Registered: ‎11-28-2008
My Device: DTEK50 (AAI82), PRIV (AAI795), Z10/Z30/Q10 (, Playbook (
My Carrier: TMobile USA

Re: Torch went blank and nuked itself.

Hi and Welcome to the Community!


Unfortunately, even though you have told us quite a bit, you unfortunately also said things like "Been through all the KB stuff on it and still no fix"...sadly, there is no way for us to know what you've already tried unless you are very explicit. So I risk providing you with redundant information here.


Nevertheless, since you also were not clear about these preparatory set of steps, I recommend this process, on a PC (you cannot do this on MAC):

1) Uninstall, from your PC, any BB OS packages

2) Make sure you have the BB Desktop Software already installed

3) Download and install, to your PC, the BB OS package you desire:

  • http://us.blackberry.com/support/downloads/download_sites.jsp
  • Since you cannot boot up your BB, you cannot check the version that it is presently running. So you will have to choose one...I recommend something in the 7.1 range, as high in that range as you can find. The last time I checked, the highest for the 9860 was, but there could be later versions.

4) Delete, on your PC, all copies of VENDOR.XML...there will be at least one, and perhaps 2, and they will be located in or similarly to (it changes based on your Windows version) these folders:

  • C:\Program Files (x86)\Common Files\Research In Motion\AppLoader
  • C:\Users\(your Windows UserName)\AppData\Roaming\Research In Motion\BlackBerry\Loader XML

Now try the various tricks to get the OS to load:


There also is this list of troubleshooting articles...hopefully something will be useful (again, advance apologies for any redundancy):

  • http://supportforums.blackberry.com/t5/BlackBerry-Desktop-Software/Tips-for-getting-BlackBerry-Deskt...
  • KB10144 How to force the detection of the BlackBerry smartphone using Application Loader
  • KB28457 BlackBerry Desktop Software is unable to detect the BlackBerry Smartphone due to administrative permissions
  • KB28458 BlackBerry Desktop Software is unable to detect the BlackBerry Smartphone when user account control is enabled
  • KB28459 BlackBerry Desktop Software is unable to detect the BlackBerry Smartphone when a full version of Roxio® Media Manager is installed 
  • KB28456 BlackBerry Desktop Software is unable to detect the BlackBerry Smartphone when USB selective suspend setting is enabled
  • KB28444 The BlackBerry smartphone is not detected by BlackBerry Desktop Software when connected by USB to a USB hub or a docking station
  • KB28443 BlackBerry Desktop Software cannot detect the BlackBerry smartphone when it is connected via USB
  • KB02640 Troubleshooting USB connections
  • KB15486 Top 10 BlackBerry smartphone and BlackBerry Desktop Manager troubleshooting tips
  • KB00125BlackBerry Desktop Software cannot detect the BlackBerry smartphone
  • KB11439 BlackBerry Desktop Software does not detect the BlackBerry smartphone when it is connected
  • KB00019 No PIN displayed in BlackBerry Desktop Redirector
  • KB10938 "USB charging current is insufficient" appears on the BlackBerry smartphone
  • KB01451 How to turn on advanced synchronization logging if a wired synchronization fails
  • KB19717 The BlackBerry smartphone is not detected as a USB Mass Storage Device when connected to a computer
  • KB16310 Media Transfer Protocol and the BlackBerry Storm smartphone
  • http://supportforums.blackberry.com/t5/BlackBerry-Desktop-Software/Desktop-Manager-quot-disconnected...

Also, check that you are using only root USB ports...no hubs (sometimes the front-side ports are hubs...use a rear USB port). And make sure to try disabling USB power management in your system configuration (Device Manager).

Also check on conflicting software...it has been reported that the software package NTI Shadow&Ninja can cause a conflict; removing them and reinstalling the BB desktop software allows it to install correctly.

Apologies in advance if this is redundant -- there's no way to be sure if you've already seen and tried these. Also apologies if any are not presently available...RIM takes them up and down at will as they revise things.


If you continue to receive the same error, then sadly it sounds like there is a hardware problem...and no amount of internet-distance diagnosis nor OS/Software solutions can help that situation.


Good luck!

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 3
Registered: ‎04-21-2013
My Device: Torch 9860
My Carrier: MTN

Re: Torch went blank and nuked itself.

Thanks sd. A well presented and comprehensive post that should be a sticky. It applies to all BB's.

I did most of what you say but it took me a week to find all the methods in different forums and sites and now its all in one place. Must bookmark this.


Unfortunately I gave up on it and it is now at a repair shop. The guy said that he had to purchase expensive software from RIM that does diagnostics on hardware and software and installs OS's.


Will post the results tomorrow.

New Contributor
Posts: 3
Registered: ‎04-21-2013
My Device: Torch 9860
My Carrier: MTN

Re: Torch went blank and nuked itself.

Repair shop could not fix it so I sent it off to BerryFix today.