Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Posts: 1
Registered: ‎04-29-2013
My Device: Curve 9360
My Carrier: Koodo

Trackpad not working after disassembling

So I had accidently dropped just a bit of water on my phone (litterally just a bit). I put it in rice (i've done this with 4 other phones and it worked magic) and after around 35 hours I went and check to make sure it was okay. I put the battery in. It didn't work so well.....everything was still the way it was when I had dropped water on it.


So anyways, today I found a solution on another blackberry forum. When I put the battery in from the rice a few keys weren't working (Q,W,ALT,space) Someone said to do a full cleaning of it (litteral cleaning) so I followed a video online to dismantle the blackberry and cleaned all the things I can (i.e keyboard inside etc,) and put it all together and it worked! My keys were working perfectly....except....the track pad. I've tried the following:


-Battery Pull

- Checking the wiring of the trackpad

-Rebuilding it all over again.



Nothing seems to be working to get the trackpad going. I just can't scroll I can click it but that's it. Any suggestions? The people here are so helpful so i Thought i'd give it a try!


Phone is a  blackberry bold 9360 or 9320 idk

Posts: 4,285
Registered: ‎07-26-2010
My Device: Q10/Q5/Z10/9930/9860/9310

Re: Trackpad not working after disassembling

Hey CanadianCrackberry,

Welcome to the BlackBerry Support Community Forums.


Thanks for the question.


I would suggest following the steps in this KB article to get your trackpad working: www.blackberry.com/btsc/KB29640


Let me know if you have any more questions.





Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp

Be sure to click Like! for those who have helped you.

Click  Accept as Solution for posts that have solved your issue(s)!